Wallpanel Battery Management

I think I have fixed it.

Let me know if it works now.

:+1: Thanks muchly!

1 Like

Thanks! I had plans for creating exactly this automation.
Since my switches are Philips Hue light switches, I had to find/replace all ‘switch’ with ‘light’ in the Blueprint.

1 Like

That’s good, glad it works for you.

thank you very useful, I’m using it for a smartphone that is always connected to the electricity grid. As a further improvement it would be very nice to be able to introduce a logic to prioritize charging during the night when electricity is cheaper. Do you have any plans to produce something like this?
thank you

1 Like

Thank you.

I do not have any plans to modify this at the moment, but the blueprint files are reasonably easy to modify, you could make a copy and have a go at modifying and updating yourself and let me know how you get on.

thanks for this

1 Like

Just what I needed, thank you! My attempt was an epic fail so I was pleased to stumble across yours which addresses my Home Assistant start-up issue.

1 Like

Hi, I am new to HA, have tried to use your blueprint, to control power charging to my wall tablet running HA but can’t seem to get it to works - What am I doing wrong - any help would be appreciated

  • id: ‘1639341639065’
    alias: 'tablet test ’
    description: ‘’
    path: seamus65/wallpanel-battery-management.yaml
    battery: sensor.galaxy_tab_a7_battery_level
    charger: switch.latched_hidden_switch_single_switch_1


Are you seeing the battery percentage in home assistant from sensor.galaxy_tab_a7_battery_level?

Can you manually control switch.latched_hidden_switch_single_switch_1 from home assistant and does it control the charge of the tablet?

Thanks for responding

Yes, and I can switch the unit on and off, just not via the automation

Also forgot to Mention that I’m using for fully kiosk on the tablet

Am getting these warnings in my log for the automation using this blueprint. Is anyone else seeing these? I have filled in all of the fields for the automation and it does work. Just trying to understand why I would be getting these warnings.

* Error in 'HABoard01 Battery Management' trigger: In 'numeric_state' condition: no entity specified
* Error in 'HABoard02 Battery Management' trigger: In 'numeric_state' condition: no entity specified
* Error in 'HABoard03 Battery Management' trigger: In 'numeric_state' condition: no entity specified
* Error in 'HABoard04 Battery Management' trigger: In 'numeric_state' condition: no entity specified

I got and old tablet (galaxy tab 2 10" )
I installed a custom rom for using at least the android 6.0, but in kiosk my dashboard is on white mode, even with webview updated…

is there something to change to dark mode version?

got it!

just tap on my profile and change dark.

hi I have imported this blueprint but when I setup I get error 500 message:

Perhaps this link can help you trace your issue:

Sounds like it may be an issue in your automations.yaml file

Anyone else seeing issues under HA 2022.10.x where occasionally entities go unavailable at the exact time the automation executes and so the action does not happen? My charge controller has been working a gem up until 2022.10 and recently it either completely discharges or hits 100% and then of course, never cycles the power switch so the charger stays on.

See what happened at @ 0751 this morning when the battery reached 80% and the blueprint went to turn off the device. It ended up leaving the charger on which is not good.


@ xbmcnut I haven’t seen exactly that (AFAICT), but I have seen the turn on / off action just silently fail to happen a couple of times.

I’m using this blueprint with an Amazon Fire tablet. HA is running in not-yet-licensed Fully Kiosk web. USB charging goes through one of those very cute Sonoff Micro USB charge switches. Home Assistant 2022.10.5, Frontend 20221010.0 - latest

Most of the time, this works perfectly for both high (90%) and low (30%) charge percent values. I see a nice triangle wave with no breaks. A few times, maybe every 3-4 days, the ramp up or down does not stop at the configured value. It either charges all the way to 100% or discharges to 0% and the tablet turns off.