[WARN] Home Assistant CLI is not running!


I recently installed Home Assistant Operating System using VirtualBox on Windows 10. I was able to log in using “root”, and afterwards downloaded the Mobile App for my iPhone where I created a username and added my TP-Link HS110 Smart Plug.

I wanted to download the File Editor so I could try changing the configuration file. However, when I went into “Supervisor-> Add-on’s -> File Editor -> Install”, it came up with an error regarding the supervisor.

I then decided to restart HA through the browser “xxx:8123” and managed to log in fine. Lastly, I rebooted my Virtual Machine and now I get the following error:

I have tried re-creating a new VM but I have the same result. I also haven’t been able to find answers online or in the forums yet that I could understand for my application.

Is somebody able to help me out?

Thanks and best regards,

1 Like

So… yesterday it randomly started working again when I commenced my work day, and I didn’t touch it for the whole day.

Today, this error came up again and while experimenting I simply typed in “exit” in the console, and then logged in again as “root”. It launched Home Assistant again fine.

I find it strangely unstable that it does this, but hopefully this is a reliable interim solution.

1 Like

Hi there,
i am facing the same issue at each reboot :frowning:

sometimes root/exit works
sometimes i need to update /etc/systemd/timesyncd.conf

systemctl daemon-reload
systemctl restart systemd-timesyncd.service
systemctl status systemd-timesyncd.service

Oof… that sounds like this needs a bit more attention…

1 Like

These commands fixed the boot issue, thanks @acognard

systemctl daemon-reload
systemctl restart systemd-timesyncd.service
systemctl status systemd-timesyncd.service

If anyone cares to replicate, I ran into this on a fresh proxmox/VM install of hassos_ova-5.13.qcow2. First login to HA for setup was no problem. I added two USB devices to the VM and rebooted and ran into the issue.


I discovered HA two days ago and I am in the testing phase. I am having the same problem and the solutions work randomly.

I am not an expert but I try to heal myself.

If I understand the CLI correctly, this is the command line? If we use the local GUI at http: //homeassistant.local: 8123 / is the CLI useful?

I keep discovering, thank you

[Automatically translated, sorry if some sentences are not correct …]

The HA-cli is a container. When you reboot the host, everything needs to start up again. When you login as root immediately after a reboot the ha cli is not running yet. You then “exited” and logged in again once the HA cli was running.

There is no reason to login here anyway, as this does not start Home Assistant.