[WARN] Home Assistant CLI not starting! , New install on PI 4 B

Setup:-

Raspberry Pi 4 B 2GB with a Kingston 240GB SSD or 32GB SD card or another SSD

I followed the installation steps in Installation - Home Assistant

1 download the recommended Home Assistant OS 12.3 RPI 4/400 for RPi 4

2 Flash the SSD with the image, using Raspberry Pi Imager, I also tried BalenaEtcher.

3 Insert the SSD into RPi 4 and power on it with a monitor, keyboard and mouse plugged in.

The screen shows the installation until: -

[OK] Reached target - System Time Set

[FAIL] Failed to start – Wait Until Kernel Time Synchronized

See ‘systemctl status systemd-time-wait-sync,service’ for details.

[OK] Reached target System Time Synchronized

.

.

.

.

Waiting for Home Assistant CLI to be ready

[WARN] Home Assistant CLI not starting! Jump into emergency console….

It just hangs at this point.
I have tried multiple times to install Home Assistant on my Raspberry Pi 4B using different SD cards and two SSD’s and the installation fails at the same point each time.

I can install the latest operating system on a card or SSD with no problem so I know the hardware and network connection are both ok.

Home Assistant was working fine on my SSD until recently when I stupidly closed my browser mid update.
Am I doing something wrong or is there a bug in the image, please help?

The first thing to always look at with an RPI is the power source.

Yes, it worked before doing ??? and now it does not. Or, blah blah blah.

But, the fact is that they all run off of cheap Chinese PSes. They die (or more likely don’t work to specs after time). Try another one!

Thanks for your reply, I just tried a different PSU again - still fails :frowning:

And how long did you “waiting” before you rebooted/closed the show ?

At least an hour as I forgot about it :slight_smile:

Well the thing is you don’t provide much info in regards to what you have done/tried.
And in Regards to your Topic header, the Answer is a BIG , NO it’s not !
Below Google search will give you an idea of which “Rabbit Hole” you are facing :wink:

[WARN] Home Assistant CLI not starting! Jump into emergency console - Google Search.

So, in such a “use-case” the more, And even more relevant info is needed
And most of all in a structured/detailed way

Some solved by just typing, login in the cli, and then typing the IP:8123 in their browser, others had to be more creative

PS: I even saw one mentioning that BalenaE Dont wipe the disk/card partitions(should be done in proper manner from other tools), as it could cause insufficient space( in some cases )

PS: If you are able to type login, you even get access to i.e Logfiles and network/dns settings etc

This is not a bug!
It’s the ssd cable that goes to the Pi
You had to look up first
What cable will work
Cause not all of them will work!
I had the same issue…
Toke me awhile to find out tho…
ya need a startech one! go look up the net for the proper cable!

It is not the cable as it fails with a number of SD cards and also two different SSD with there respective USB cables.

The Home Assistant was working on my Raspberry Pi 4b 2GB with the Kingston SSD / cable until I stupidly closed the browser in the middle of an update.

I have installed Raspberry Pi OS on the two SSD’s and also a number of SD cards without any problems, so I know my hardware works.

You could basically add “your experience” to the url i posted above

However OP have tried various medias/cables so as he says “not that hardware”

Best would be to make sure the media sd/ssd is wiped properly before “flashing” it with the HA image, and as jeffcrum mention

They all tend to loose “performance”, meaning try another With More Amp’s

And dont flash from an online source ( Download the source first )

When booted and receiving above “Not trivial, but very known Message” wait a little longer, it can take time depending on various factors ( As one can read about in various similar topics )
then try “typing” login etc.
It “Hangs” means it literally HANGS, so don’t use that word if you’r not 100 upon that, which you are not if you just look at your screen
PS: Connecting a monitor/keyboard/mouse to your PI, does for sure also requires more “power” so make sure the “others” PS’s you tried in fact have better performance, and not is some trash you had laying around from other old devices

And report back in a detailed, structure “report” where you have tried to actually access the HA( If possible) , that message doesn’t have to mean that you can’t

PS: I changed Your Topic Header, to Reflect your Issue

First ya should tell if ya use 64 bits or not…

Because that was indeed the issue…for me
The 64 bits install not worked exactly as ya told
32 bits I didn’t try…
After getting that new cable 64 bits worked flawless
Ya did not tell what version you try to install…
So from there I’ll suspect ya try to install 64 bits…

so my solution >>
https://jamesachambers.com/new-raspberry-pi-4-bootloader-usb-network-boot-guide/

this>>
go look!

I also!!! raspberry 4
use raspberry OS is OK!
but use Raspberry pi Imager 1.8.5 and HAOS12.3 is not ok!!!

Try HA OS 12.2, 12.3 is buggy

Version 12.3 is buggy. I found a solution for myself to install version 12.3. Maybe that will help beginners. You need to install the Version 12.3 via Pi Imager on a Micro SD Card first, but then the SD must be cloned to the SSD via Balena Etcher. The following link describes how installation via Etcher. Here is the link to the instructions: Raspberry Pi - Home Assistant
Now go to Etcher click on the SD as Source (BE CAREFUL, DONT TAKE A WRONG SOURCE!!!), then select the ssd as target and flash it.

If HA is already running on a Micro SD card and you want to switch to SSD, you can simply use the existing SD card; a new installation is not necessary.

2 Likes

Hi, everyone. I found a solution using ChatGPT. Follow these steps:

  1. Edit the /etc/systemd/timesyncd.conf file.
  2. Replace ‘time.cloudflare.com’ with ‘pool.ntp.org’.
  3. Reboot your system.