WARNING [supervisor.auth] the user ‘myId’ is not registered"

I can’t login to my HA even I got proper login and password. When I do on my HAOS CLI: tried on my ha cli: au reset --username "marcin" --password "newpassword"
and get Error: unkown error, see supervisor
EDIT: on supervisor logs got info that: " WARNING [supervisor.auth] the user ‘marcin’ is not registered"

Same problem here. This is really bad. Will be very unhappy if I have to nuke my whole install because of this.

having the same issue. Used “grep username .storage/auth”
and it returned my username.

Once I tried to change using “auth reset” I get the same “Unknown error see supervisor”. The log then says my username is not registered.

I have the same issue. I can’t delete the user to recreate it either.

ok, so I looked at my root/config/.storage/auth file upon looking at that, I found that the username displayed in home assistant is NOT the same username I log in with. The username I log in with is in that file, and once I found that, I was able to log in.

the same issue here, but the user name is totally the same as in config/.storage/auth…

UPD: the answer is Display name is not the same as User name… all needed in “credentials” section:

    "credentials": [
        "data": {
          "username": "admin"