watchOS required version changed?

Hi all,

I’m wondering if anyone with an Apple Watch which meets the requirements in the docs is having issues installing the watchOS companion for the 2024.1 Mobile App release - see my post in reply to the 2024.1 iOS release here.

Short version: Console says the install process is not finding the app for “this device” (my watch).

I have a Series 3 with watchOS 8.8.1 and I thought it might be worthwhile seeing if anyone else is having the problem as of a certain Series or OS version, or if I’m an outlier for some other reason.



Hi Sean,

I have a similar issue, at least it behaves like mentioned by you in the post it reply to 2024.1.
I also have a Series 3 Watch on OS 8.8.1.

When trying to install the Home Assistant WatchOS app via the Watch app running on my iPhone, the circle spins for some time and then the process fails silently → back to the start.

When trying to do the same using the App Store App on the Watch itself it’s giving an error like “Request couldn’t be processed. Please try again later.”

Unfortunately I don’t have a solution for this, but I want to share some some of my experience with this, if somebody is interested:
Actually I sumbled upon this issue by accident, since I have the same issue with another (new) WatchOS app since some weeks.
In the beginning I had the feeling the issue is limited to that specific app, since a lot of others I tried were possible to install and uninstall w/o any issue at all, so I contacted the App developer and was really sure it’s an issue on their side - somewhere on the “distribution” side of things or a compatibility issue…whatever :slight_smile:
I provided a lot of info, it was going back and forth for some days, but then they said it’s not on their side/they (allegedly) can’t reproduce it and sent me to Apple.
(Which I never contacted so far, since I have the feeling it’s pointless, esp. with such an “old” device…)

Now after some time I tried it again: I’ve reset the Watch completely and re-paired it again, but this time I did it without using a backup, so pairing it as new Watch (as a last resort…)
After pairing the Watch all available WatchOS app’s were automatically installed (default setting), but four of them were left to “install”…
One of them is Home Assistant and another one of those is the app which is causing issues for me since weeks…
The other two can’t be installed as well, behaving the same.

So there is a high chance that the root cause of this is the same and I would be very interested in a solution to this or any (real) hint to fix it, esp. since there are not much useful resources available around this topic.


Well, I’m glad I’m not alone - although I’m also sorry you’re experiencing this as well!

I would not bother with Apple - they will only suggest what you’ve already done. I’m certainly reluctant to reset and start from scratch – not that I have a whole lot of config on my watch, but it’s still a pain in the arse.

Thanks for replying, I’m hoping maybe 2024.[>1] will fix it :slight_smile:


1 Like