Watson TTS - Can't configure a voice

As the title says:

  - platform: watson_tts
    watson_apikey: !secret watson_tts_api_key
    voice: en-GB_KateVoice



Try adding quotes. It should be valid looking at the code. 'en-GB_KateVoice'

Yes, I already tried that, same error…

  - platform: watson_tts
    watson_apikey: !secret watson_tts_api_key
    voice: 'en-GB_KateVoice'


You on the lastest and greatest version? I don’t see how voluptuous could fail there.

What does your config look like around that section?



Watson is the last thing in the file in which it appears, like this

  - platform: microsoft
    api_key: !secret microsoft_tts_api_key
    language: en-gb
#    gender: Male
#    type: George, Apollo
    gender: Female
    type: Susan, Apollo
    rate: 0
    volume: 0
    pitch: default

  - platform: watson_tts
    watson_apikey: !secret watson_tts_api_key
    voice: en-GB_KateVoice

Donno man, I’m stumped. Might be worth a Issue on github.

I’ve just looked at the source code, and it looks like there is a bug. Here is the list of supported voices:


Note the missing comma between “de-DE_DieterV2Voice” and “en-GB_KateVoice”.
My understanding of Python is that this would result in in being treated as a concatenation. This would prevent either of those 2 voices from working, but the others would still work. I’d raise an issue on GitHub here about this - I’d do it myself and issue a pull request to fix it, but Im on holiday and don’t have access to my computer (typing this on my phone).


@Steven_Rollason, Good catch. just tested and this was the issue
I will se about submitting a PR to fix

1 Like

Man, I was looking at the code for 10 minutes and I didn’t notice that.

1 Like

Whats worse is that he found it whilst looking at it on his phone, bloke must have superman eyes


PR submitted and will be in 0.94.3

1 Like