Waveshare CM4-POE-UPS-BASE not booting with NVMe

hi all,
did someone already used the Waveshare CM4-POE-UPS-BASE board with a CM4-8GB-32GBeMMC-WIFI-BT with installed NVMe with HA 9.x? I tried a few combinations but the board wont come up with HassOS 9.x. What I tried:

  • :white_check_mark: eMMC + NMVe + RaspbianOS (lite)
  • :white_check_mark: eMMC + RaspbianOS (lite)
  • :white_check_mark: eMMC + HassOS
  • :no_entry: eMMC + NMVe + HassOS

I used the rbiboot way and usb-slave connection. This works nice for all so far. Only when I plug in the Crucial P3 500GB CT500P3SSD8 PCIe 3.0 3D NAND NVMe M.2 SSD the screen keeps being black. It wont boot also, when I start without the NVMe and later install it. everytime the NVMe is installed it wont come up - but only with HassOS. Raspbian works like a charm.

I also saw these posts…
HassOS issue 2075
HA Yellow - CM4 Lite + NVMe - Won’t Boot??

Any idea how to solve this? If it is “just” a driver issue… maybe spending a few more MiB for proper driver set would help and is not wasted space - usually 200MiB es available for the case that is make the whole 200€ piece usable. :wink: