Waveshare ePaper with Adafruit HUZZAH32 ESP32 d

I am an absolute beginner :wink:
I would like to operate a Waveshare epaper 7.5 incl. Hat (7.5inch e-Paper HAT - Waveshare Wiki) with an Adafruit HUZZAH32 ESP32 (Adafruit HUZZAH32 – ESP32 Feather Board : ID 3405 : $19.95 : Adafruit Industries, Unique & fun DIY electronics and kits) .
Unfortunately I can’t do that.
I currently wired it as shown in the picture:

and it looks like this in the YAML config.

  name: wohnzimmer-wetterdisplay
  platform: ESP32
  board: featheresp32

///////////"REMAINING CODE"

  clk_pin: 5
  mosi_pin: 18
  - platform: waveshare_epaper
    cs_pin: 15
    dc_pin: 33
    busy_pin: 32
    reset_pin: 27
    model: 7.50inv2
    update_interval: 300s

Has anyone of you already done that? Is the wiring wrong or the GPIOs in the YAML?

“I can’t do that” isn’t helpful. What exactly is your error?

Can’t even see your wiring - what pin is connected to which pin?

7.5inv2 is not a valid option, I read 7.5inV2

Oh and you haven’t written anything to the screen?

@draexler Did you get your 7.5inV2 Waveshare working? I have one of these, verified the hardware is good via Raspberry Pi and demo code, but cannot get it working in ESPHome on an ESP32. I’ve tried many many things, different pinouts, different types of ESP32 boards, but here’s my current code. It does nothing, no flicker, no nothing:

  devicename: ESP32Display
  gpio_spi_clk_pin: GPIO13
  gpio_spi_mosi_pin: GPIO14
  gpio_cs_pin: GPIO15
  gpio_busy_pin: GPIO25
  gpio_reset_pin: GPIO26
  gpio_dc_pin: GPIO27
  name: esp32display
  platform: ESP32
  board: esp32dev



  password: !secret ota

  ssid: !secret wifi_ssid
  password: !secret wifi_password
  fast_connect: true

    ssid: "Esp32Display Fallback Hotspot"
    password: !secret wifi_password


  clk_pin: $gpio_spi_clk_pin
  mosi_pin: $gpio_spi_mosi_pin

  - platform: waveshare_epaper
    id: epaper
    cs_pin: $gpio_cs_pin
    busy_pin: $gpio_busy_pin
    reset_pin: $gpio_reset_pin
    dc_pin: $gpio_dc_pin
    model: 7.50inV2
    update_interval: 30s
    lambda: |-
      it.print(0, 0, id(bold_14), "hello world!");
  - file: 'fonts/Google_Sans_Bold.ttf'
    id: bold_14
    size: 14

Trying to get the same 7.5inV2 working myself. I tried both the B&W and BWR versions - the screen never flickers or comes to life with these settings. My 4.2 inch works fine…