We couldn't find an OpenZWave instance. If you believe this is incorrect, check your OpenZWave and MQTT setups and ensure that Home Assistant can communicate with your MQTT broker

as the title says

the install of Home assistant is Venv

took a bit to get MQTT installed but this is now talking to Home assistant but even after full reboot it still has this error

this is a full clean install of Home assistant with no other Zwave intergrations

also no clue on how to install this either OZWDaemon

Let me try to summarise:

  • You have installed Home Assistant in a virtual environment.
  • You have installed an MQTT broker and connected that to Home Assistant.
  • You have not installed ozwdaemon, but you have connected a ZWave USB stick.
  • You are trying to add the OpenZWave integration, and then get the error message in the title.

The documentation proposes a few options. I am running Home Assistant in Docker, and have decided to also run ozwdaemon in Docker which is documented as well and if you want to go down that path, you really only need to define those environment variables that are deviating from your setup.

you have surmised correctly my traditional Zwave intergration is working but has not been updated in over 2 years so figured I better get this MQTT thing figured out

I don’t have docker I am Running Venv and docker instructions does not apply, so trying to find the path to install ozwdaemon via python to see if that corrects the error

ozwdaemon is only distributed as a docker image, it’s not a python project. I think someone has created a snap version. Otherwise, you’ll have to build it yourself or extract the files from a docker image.

I found this and installed it but still getting the same error

pip install python-openzwave-mqtt

That’s the python package HA uses to interface with ozwdaemon. Installing it doesn’t help you.

I would not even know where to begin to extract files

so openzwave beta is not for Venv installs I gather

You can use an HA venv install and run ozwdaemon in docker.

I don’t have docker nor do I even have the first clue on installing it let alone using it

What OS are you using? If its linux, have a look here: https://docs.docker.com/engine/install/
After you installed it, add create a group docker with sudo groupadd docker and add yourself to it with sudo usermod -aG docker $USER and apply that with newgrp docker then test if you can do anything with docker with docker run hello-world. Then, if docker doesnt start on boot and your distro uses systemd, use sudo systemctl enable docker to start it. Then you can follow the intructions on the ozw-daemon github page.

I am hoping you can help, I have this same error, I am running Core in a ubuntu 20.04 venv. I have an installed and tested MQTT server, works with HA on my network. I installed two snaps for ozwdaemon and ozwadmin. Ozwdaemon is running on host , with Aeotec gen 5 stick, and configured with my MQTT credentiials, and usb location dev/ttyACM0, which I checked. I get the error above when I try to configure Open Z-wave beta. I also tried the ozwadmin gui, it says to run a command:

 snap connect ozwadmin:ozw-config ozwdaemon:ozw-config

, but I get error: snap “ozwdaemon” has no slot named “ozw-config” Any suggestions where I am going wrong, thanks.

I just decided to stay with the older Zwave plugin it still works and it works with Venv installs

So if anyone else finds this, this snap install of ozwdaemon worked for my core install on X86PC in Ubuntu20.04 Venv (no Docker):

sudo install -y snapd
sudo systemctl enable --now snapd.socket
logout and log back in as root
sudo su -
snap install ozwdaemon
snap get ozwdaemon -d

Review the configuration shown, if you need to change something use snap command set, example:

snap set ozwdaemon usb-path=/dev/ttyACM0

when happy with config run:

snap connect ozwdaemon:raw-usb
snap start --enable ozwdaemon.ozwdaemon

Then install OpenZwave-beta in HA, and restart, this worked for me, YMMV, you may need to adjust for your distro or hardware.

this does not work at all as you have it listed

below is how I was able to get snapd installed

sudo apt install snapd -y

sudo systemctl enable --now snapd.socket

sudo reboot

sudo snap install core

sudo su -

however trying to install ozdaemon

snap install ozwdaemon

I get this error

error: snap “ozwdaemon” is not available on stable for this architecture (i386)
but exists on other architectures (amd64, arm64, armhf, ppc64el).

and I am running a KVM64 VM

As I said YMMV, but it most certainly worked for me; but I am on X86 PC, Ubuntu20.04 in Venv. It looks like snap package manager is saying there is no snap for your architecture. So… the docker way, or pull the files from the docker image and manually build it. That is beyond my ability to help with, I was just trying to help anyone else in my situation. I will add the architecture to my post, may be clearer.

i386 is X86 platform My pc is a 64bit platform running proxmox running a on 64 bit snap thinks it is running a I386 is the issue

if I knew how to do that I would not be on here looking for help

Ok, I am no expert but in my old world view, x86 is a 64bit processor, I386 is 32 bit, so to me its not the same architecture, snap seems to agree. I am certainly no expert, just spending my time trying to help you. I will bow out, maybe someone with more expertise will jump in.

I386 486 586 and 686 are part of the x86 family here is a good chart