Weather Forecast Card not displaying in Lovelace

I can’t get the weather forecast card to display in Lovelace, I can only see the edit bar in ‘configure UI’ mode but nothing at all in normal view (it displays OK in the states UI). The configuration looks to be correct and don’t see anything in the log files. Tried it in all versions 0.90.x and 0.91.x but get the same result. Below is an extract from my configuration file:

  - platform: darksky
    api_key: !secret darksky_key

and the card configuration is:

entity: weather.dark_sky
type: weather-forecast

This all looks okay. How exactly is your card configured? For example, mine is configured like

  - title: view1
      - type: weather-forecast
        entity: weather.dark_sky

The view configuration also looks to be OK:

      - entity: weather.dark_sky
        type: weather-forecast

Check your white space. The formatting you posted here has an extra space after cards:

That’s just a cut and paste error, the formatting of the real config is correct.

Did you resolve this? I had this working and realized the card disappeared. It was in a stack but I pulled it out and put it explicitly by itself on a separate tab and it is not appearing at all.

Where does one look for errors?

I checked the dark sky site and am under my quota and my account is still good.

I haven’t got a resolution to this issue yet, nothing I’ve done has made any difference. I’ve even tried reinstalling Hassio from scratch with just the weather forecast card in the UI but to no avail. My dark sky subscription is Ok, the configuration is all OK and I don’t see any errors, it just doesn’t work!

I don’t know precisely when mine stopped, but I think it was either 0.90.x or 0.91.4, it had worked fine before.

I also have found that it works on Chrome and Firefox but not on Edge. I can’t get HA to come up at all on Internet Explorer.

I had switched to Edge because with 0.91.4 Node-Red would not work on Chrome, only Edge.

So it appears there are a lot of browser specific problems being introduced of late.

I’m using Edge but I’ve just tried it with Chrome and that works OK so I agree it looks like a browser specific problem.

I opened an issue (hopefully correctly, first try).