'weather.home' provider forecast broken for me

I’ve had this issue for a while; and, would like to get to the bottom of it. When displaying the regular weather card (using weather.home provider), the temperature for the last few days is missing in the forecast.


I also tried using the custom weather card, same issue:

I tried switching to OpenWeatherMaps provider, however, I ran into a completely different issue… so, thought I would just focus on getting the builtin weather card/provider to work correctly.

Also, I upgraded to Home Assistant .110 thinking it would resolve this issue, however, I still have the same issue.

I’d really appreciate help to get this working correctly.

Can you share the state and attributes of this entity from your developers tab? It is possible that this integration doesn’t supply a 5 day forecast for your area.

There are many built in integrations for weather you could choose from. This one is only special because it is set up when home assistant first starts. It doesn’t make it a more accurate or reliable source IMO. This integration is met.no.

Thanks for your reply. Below is all the information from the entity. When I use the weather provider: weather.openweathermap, I don’t even have an option to select forecast. It only has hourly info it for one day. It’s not like I live in a remote rural area either. I live in a densely populated area in California that’s very popular. OpenWeatherMaps display correct forecast information for my area outside of Home Assistant.

Could you please recommend a few good integrations that displays good weather forecast information for United States? So far, whatever I tried doesn’t seem to work.


temperature: 73.8
humidity: 46
pressure: 29.92
wind_bearing: 248
wind_speed: 0
attribution: >-
  Weather forecast from met.no, delivered by the Norwegian Meteorological
  - datetime: '2020-05-22T12:00:00-07:00'
    temperature: 68.2
    condition: partlycloudy
    pressure: 1014
    humidity: 46.3
    wind_speed: 12.6
    wind_bearing: 225.7
  - datetime: '2020-05-23T12:00:00-07:00'
    temperature: 76.5
    condition: partlycloudy
    pressure: 1013.6
    humidity: 35.3
    wind_speed: 10.8
    wind_bearing: 233.8
  - datetime: '2020-05-24T12:00:00-07:00'
    temperature: null
    condition: partlycloudy
    pressure: null
    humidity: null
    wind_speed: null
    wind_bearing: null
  - datetime: '2020-05-25T12:00:00-07:00'
    temperature: null
    condition: sunny
    pressure: null
    humidity: null
    wind_speed: null
    wind_bearing: null
  - datetime: '2020-05-26T12:00:00-07:00'
    temperature: null
    condition: sunny
    pressure: null
    humidity: null
    wind_speed: null
    wind_bearing: null
friendly_name: Home

dump question did you try a (ctrl+R) reload the page

if you click once in the weather card does it pop show you the forecast

Unfortunately no…

that good we know where the problem is its the sensor not having the data

just had other look at your sensor its got thoses null in it

so its not you
have you look at the met.no site Norwegian see if the data is there

See list of weather related integrations here. https://www.home-assistant.io/integrations/#weather

Have you tried the ‘freedaily’ mode in openweather map? See https://www.home-assistant.io/integrations/openweathermap/

You can also try darksky (will be discontinued in about a year since Apple bought them) or NWS.

1 Like

Man, I feel so dumb. I completely overlooked the “mode” setting for OpenWeather. Duh! It works perfectly. Thank you so much.

PS: I tried to use darksky, however, they don’t distribute new API keys anymore… they seem to only let people with existing API keys to continue using their service until they turn if off their service.

1 Like

Same issue here for the Sydney, Australia. The forecast from the default met.no site only provides two days of forecast the other three are blank.