Web Interface Not Accesible on First Install

Hey all,
I am brand new out of the box to the Home Assistant world, and I am excited to get going with it. However, I am running into issues accessing the Web Interface on my first install. I’ve tried both a Raspberry Pi 4 and a virtual machine on Ubuntu; I am confident I followed the HA instructions to the letter on both installs. The Home Assistant network shows up on my router, and I can see the Home Assistant IP address, but whenever I try to go to homeassistant.local:8123, homeassistant:8123, or the IPaddress:8123, it says that it refused to connect.
The mobile app also has issues; it just continuously scans for the HA network. I’m thinking that it may be an issue with my internet, but I don’t even know where to start troubleshooting that. Any help or guidance would be greatly appreciated. I am a noob when it comes to programming and these things, but I am willing to learn. And if I am in the wrong category of the forum, just let me know and I can post it elsewhere. Thank you!

BCunningham210

hello
seems u need to open or redirect the 8123 port.
first you have to get it working locally

  • maybe look at your vm network settings.
  • yesterday a guy needed to open the port under ufw (ubuntu firewall).
  • on docker you have to get network_mode: host or open the port 8123

Hey Tom,
I did a quick search online and there was this port checker to see if the port is open. I entered my router’s IP address and the 8123 port and it said the port is closed. I followed the instructions on the VM installation, where it says to go to Network, bridged, and choose the adapter. Is there some other setting that I am missing? I didn’t see anything about ports. I will check the ubuntu firewall and mess around with it. Is there a guide out there on how to open the 8123 port?

as i said you don’t use online tool.they are useless till your home assistant installation isn’t reachable locally.later when it will work locally, you will need to open port in your router to get it work trough the net. forget that for now.
configure ufw is not very hard.
u need to create a rule something like: 8123TCP allow everywhere
look at here: http://www.linuxandubuntu.com/home/ufw-firewall-configuration-in-linux.
sorry i didn’t use a vm since a long time. what virtualisation software do you use.maybe you should go for ‘supervised installation’. or a ‘docker container’, or full hassio os (supervised under alpine linux)

It is normal, if you used an online port scanner, that the port is closed. On your pi4, you used Home Assistant OS? You got connection refused there, even after waiting 20 minutes after starting your Pi?

@francisp Yes, I even let it sit overnight. And yes, I used the Home Assistant OS on the Pi. I believe it’s Hass.io or something along those lines. As I said, I am a beginner figuring this all out. The display I had connected to the RasPi made everything appear fine. It ran through all of the scrolling text and ended on Home assistant login. Then I waited, as the instructions said, with no results. Very weird and discouraging.

@tomdudu38 I went into my Ubuntu firewall and typed sudo ufw allow 8123/tcp. It updated the rules and I verified using sudo ufw status verbose. It presented me with
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), deny (routed)
New profiles: skip

To Action From


8123/tcp ALLOW IN Anywhere
8123/tcp (v6) ALLOW IN Anywhere (v6)

So I think it is safe to say that the port is open, yes? However, homeassistant.local:8123 still says that it refused to connect.

do from host
sudo apt install nmap
nmap -p 8123 -v yourhassioipadress
it should not work that mean you have to configure your vm software network
if it work well port is open