WebOS TV Sources Disappearing from Source List

I have successfully been able to get my WebOS TV connected to home assistant but have a weird problem that I cannot seem to find an answer. Once it is initially set up my complete list of sources show that are in my configuration:

# LG WebOS Integration
webostv:
  host: 192.168.2.55
  name: 'Bedroom LG TV'
  turn_on_action:
    service: switch.turn_on
    entity_id: switch.lg
  customize:
    sources:
      - Fire TV Stick
      - Roku
      - Dish Network, LLC(Grand Rapids)
      - HDMI 4
      - Netflix
      - Plex
      - Disney+
      - Amazon Prime Video
      - Hulu
      - YouTube
      
media_player:

notify:

At first I am able to select any of the WebOS App sources, but as soon as I select an input source all of the app sources disappear. I have tested this a few times and it always happens after I have selected a WebOS app and switch to something that uses an input such as HDMI. Any help would be greatly appreciated.

On a side note, I have also noticed when I restart HA and the TV is off it becomes an orphaned object on my Overview page. I am not able to control it at this point and have to power the TV on and restart HA and it will find the TV again and the card works again. Would like to know if anyone has experienced this as well and has an answer.

Thank you in advance.

2 Likes

Which version of HA do you have?
I am on 0.109.6 and it is ok

I am on 109.6. Is it possibly something in my configuration or how I may have HA installed. I used the Linux image and have it running as a guest on ESXi.

I was also wondering if I needed to have any of the sources in single quotes.

I have the same problem, all sources except for physical inputs and Live TV disappear when any built in source is selected. HA restart required to get them back.

I don’t think it is your configuration because I haven’t specified sources and get them all at first. Running 0.110.0

Since 0.110 there was a change in de WebOS TV config i believe.
After upgrading HA made a second entity_id of my TV with a _2 at the end.
After deleting the original and changing back the name by deleting the _2 all the functions came back.

Responding to this already a bit older topic. Anyone else still having this issue? I do!

All WebOS apps disappear; As a result when going from Television (via external box and thus HDMI input) to lets say Netflix, nothing happens on the LG, only the standard menu is there. I’m on HA 0.113.2 currently. Can this be a discovery thing.I’m running HA on a docker in Ubuntu. I know there are issues with Ubuntu.

Thx,

Ralph

I’m having this issue too. I followed @heartkingz method but alas the issue returned.

This can be also done by: Configuration > Devices.
Delete original entity and rename “_2” with original name.
Using this way, no restart is needed.

I’m having a similar issue… After adding the TV (LG OLED B7) to HA, all the sources appear available and I can select them via mediaplayer card or media_player.select_source service… If I turn off the TV and turn it on, only the PHYSICAL inputs are available:


And if I try to pick an app source (YouTube) that was previously available, this error pops up:
2

To clarify, after the first time adding the TV to HA, all inputs are available (even apps), but after the first ‘restart’ of the TV (power cycle, off and on), the App sources dissappear and I can only select the physical, HDMI inputs… This behavior stays even after multiple power cycles on the TV and multiple HA restarts… the only way to see the app sources again is revoking the access via TV menu and re-adding the TV to HA, but even after that, those sources only show the first time the TV is added to HA.

1 Like

For the past day, after updating the HA core to the latest version, I’ve been getting this error:


Anyone has the same problem with WebOSTV app sources dissapearing?

I’m also experiencing this. Not the end of the world as I only really wanted to turn off the TV but still frustrating. Did anyone manage to resolve this?

Still the same issue after multiple core updates…

Looks like there is already a Github issue for this.

Any headway on this? (I posted to github as well.

Heres my yaml
image

If I restart HA, my source list matches my yaml. This is good.

If I turn the TV off and back on, I lose Peacock and YouTubeKids…
image

I’m having a very similar issue, but the goalposts seem to be constantly shifting. There is a lot of story left out, but the starting point is with the TV off.

  • Started with “LiveTV” and “AppleTV” in the sources list in my config. At some point “AppleTV” just went away and I only had “LiveTV”
  • Added elements to the config file so it looked like this (first part):
  • Restarted HA and turned the TV on manually. Now in HA the list looked like this (middle image). Notice there is now a “YouTube TV” which I didn’t even add to my config!
  • Used HA to turn off, then turn on the TV (surprised it actually worked!). Now my sources look like this: (right image)

So what the heck is going on? There are not just sources missing, but new ones show up that I didn’t even ask for!

I’d be curious to see what data is moving back and forth between the TV and HA. Is there a sniffer tool available or some other method to try to track this down? I imagine the devs understand a lot of this, I just haven’t been able to find any published info from them.

It appears there is a fix, I just dont know how I get the fix lol. Here is the github. Do I just have to wait for new version of HA?

Patience I guess. It’s merged so will be in a release soon.

The fix is included in the new 2021.4 release.

Still have this problem. Any news ?