Webpage Card only loads home-assistant.io

When I add a webpage card to my lovelace it has ‘https://www.home-assistant.io’ as the default URL. If I leave that the page loads and is intractable. If I change the URL to anything else it just says refused to connect and doesn’t load anything. I’ve tried www.google.com, www.duckduckgo.com, and a few others. Any suggestions?

Check if your url also is https

So I’m using Traefik as my reverse proxy. I can access the web service using https://hass.domain.com
From the terminal I can ping www.google.com so dns is working to the server. In my configuration.yaml I have tried both with and without the following:

   base_url: hass.<domain>.com

The I also cannot connect to it remotely. using dig on my url does return my public IP so it’s making it that far. Not being able to connect remotely may or may not be related.

The odd thing is, it loads https://www.home-assistant.io which is a https url but the others do not. Is there some other configuration I need to set or check?

Since https://www.home-assistant.io works, the sites you’re trying to embed most likely are http…

Some sites also block iframes https://stackoverflow.com/questions/8700636/how-to-show-google-com-in-an-iframe

Looks like it’s probably just sites blocking iframe. For example https://m.google.com was able to load. Too bad since it really limits what sites you can use.

1 Like

Did you manage to get this to work in the end? I would like to have my Google news feed in a webpage card but it won’t work. Not sure how to easily get around this. https://m.google.com also works for me but using https://news.google.com doesn’t.

No there isn’t really a solution if the website doesn’t allow it. At least not a sustainable solution. Best you can do is have a button or similar that takes you to a URL. It works nice on our wall mounted tablet since it just switches to the webpage, but a dumb solution on our phones.

It appears that one of the web sites that doesn’t allow this is community.home-assistant.io. That’s unfortunate; I have a Lovelace dashboard to access some Home Assistant documentation; unfortunately, I can’t include this web site that way. :frowning: