WebRTC stream works except on a tablet

I have added the WebRTC custom card. So i did the HACS part and added the integration.

The card looks like this:

type: custom:webrtc-camera
url: rtsp://admin:[email protected]:554
muted: true

This works on my Windows laptop, my Samsung S22/S20 and S10+.

But it doesn’t work on the tablet where i need it to work :slight_smile:

It needs to work on a Samsung Tab A8. It doesnt show me an real error, it just doesnt seem to start.

When i try the same RTSP link in VLC on the tablet it works fine.

Any ideas on how to make this work within the HASS app on my tablet?

I run Hass Supervised 2023.7.1 on Debian 11.

Ensure your stream is H264 encoded not H265 (some browsers especially on mobile devices do not support).

I have a similar issue with my cameras (via Hikvision NVR using rstp). They have a high quality and lower quality stream. I wanted to use the lower quality so running over 4G on my phone would perform better. However, lower quality stream does exactly as you describe however, high quality stream works. I have not yet worked out exactly why.

I did if is h264.

Do you have more stuff in the rstp://://admin:[email protected]:554?

Like / stream?

And if it was h265, wouldn’t i have had problems on my other devices?

No ideas? That would suck i bought this tablet only for this goal. Didn’t expect a stream that works on windows and android phones to not work on a recent Samsung tablet.

1 Like

Edit 1: I just remembered that I have an old Pixel 3 XL phone and decided to fire it up to see how webrtc runs on it, and guess what? It works flawlessly. Even normal HLS (not HLSLL) works just fine! Camera feed loads up instantly with no lag or delay! I’m not sure now what is preventing webrtc from running properly on android tablets. Is it really a hardware limitation or there’s a software situation that I’m not aware of.

Just chiming in on my part. Experiencing the exact issue you’re having on my Samsung tablet, that I also specifically bought for this purpose. I actually have two older android tablets that I thought were having issues streaming because they were older models, thus me getting this newer Samsung A8 tablet. But of course, the issue isn’t really that.

I currently don’t have a solution figured out yet. From what I can see this is definitely an Android streaming issue and not webrtc or HLSLL issue. Those streams work fine both on my desktop browser as well as my iPhone, so the issue must be Android related.

Ironically, most of the tutorials on youtube for a HA dashboard on a tablet are all done on Android tablets, and they all seem to work just fine, so I’m not sure why we would run into these issues.

Hi! Did you figure out, what was the issue? I just bought Honor Pad X8 (4GB memory) and lagging is real!

Same issue for me.
I can see my camera from all my devices except one…
Windows laptop with Firefox : ok
Iphone with companion app : ok
Iphone with safari : ok
Old samsung android tablet with companion app : ok
Redmi Tab SE : KO (Companion & Chrome…)
Any idea ?