Weird Zigbee mesh behaviour after power cutout

Just an update to my previous post:

Short story: I’m currently running Hassio on a RPI3, on which I’ve configured several Zigbee lights and motion sensors (both from different manifacturers) through a ConbeeII usb dongle.
More precisely, at first I installed Hassio on a virtual machine with the purpose of doing some tests, then I switched to a RPI3 and imported the whole configuration. So maybe I started with a “dirty” setup.

Anyway, it ran with major issues for 2 years. A month ago, after a long power cutoff, all my Ikea bulbs went offline and couldn’t reconnect, while all sensors were still running; after two days more, some sensors started to disconnect/reconnect randomly, while others became temporarily unresponsive despite appearing still connected.
I’ve tried rebooting the system, restoring a working backup, changing zigbee/wifi channels, rescanning for devices and so on, but nothing worked… so eventually I kept this on hold since I was very frustrated.

So until today only 2 Osram bulbs and 2 Xiaomi sensors are constantly connected and working.
Surpisingly, yesterday two Ikea lights reconnected by themselves, without any intervention!

What’s going on? I had other cutoffs without consequences in the past, so I can’t understand why now my devices are so unpredictable. I live a small house in the countryside, so I don’t suspect external interferences.

Should I create the whole thing from scratch, so to have a clean system? If so, how can I avoid the issue to occour again in the future?

I’m very frustrated and I’m thinking about giving up with Zigbee. On the other hand, I read a lot of people being totally happy with it.

Is your ZigBee coordinator dongle on an extension cable to get it away from your Raspberry Pi and, also, away from your wi-fi access point?

1 Like

Another thing I’ve found is that, after a power cut, my WiFi routers (and my neighbors) each pick a new channel to operate on. Sometimes this can introduce interference which wasn’t there before. Since Zigbee is solidly in the 2.4GHz band, it’s possible that this could contribute to your problem.

Yes, I’m alreading using an extension cable.
Moreover, the RPI and the router are in different rooms.
I’ve never changed my setup from the beginnig

I’ve tried changing both Wifi 2.4 and zigbee channels. I tried disabling Wifi 2.4 too (the RPI is connected via lan), but this didn’t help.
I really cannot explain the “inconsistency” of the issue: sometime the devices disconnect, sometime they connect and work, sometime they become unresponsive… but every device in different moment, without a regular pattern (at least, nothing that I can understand).

Wait: a couple of days before having the issue I installed a new UPS, and it’s very close (20cm) to the Raspberry: can this create any interference or whatever?

There’s one way to find out :wink:

I think we’re all leaning toward some sort of interference, so it’s worth a try. Hard to imagine what else coudl cause those symptoms.

1 Like

Ok, yesterday I did another test: I switched off my pc, nas, ups etc. so I had only my router and my RPI on (and, of course, all my zigbee devices).
After some test changing both wifi and zigbee channels, and rebooting the RPI several times, three more lights went back on, so I was quite happy …until this morining: all sensors are offline (grayed out) again!
I changed the zigbee channel and they came back… but I’m suspecting that they will get stuck/disconnect again in the next few hours.

What’s going on? I have a very simple setup and I cannot spot out the source of the interferences, if any. I’m suspecting some hardware failure, maybe caused by the power cutoff.
But this behaviour is so inconsistent that I don’t know what I should try, and I don’t have much time for testing.
I’m very frustrated and I think I’m going to give it up

That is frustrating! There’s no reason you should see that behavior. When you look at individual devices (while they’re still connected) do the signal strength numbers look good?

This seems like one of those “let’s go back to the beginning” problems. One approach would be to un-install ZHA, delete the zigbee.db database, and remove the coordinator. Then reboot, re-install and re-pair everything. A less drastic step might be to take a “problem” device and delete, then re-pair it. If that helps, then go through all of them. Less chance of success that way, but easier to do a little at a time.

Yes, it’s very frustrating indeed. Moreover, even repairing a device wouldn’t guarantee that the problem is definitely solved.
By the way, I read another user who had a similar issue ( and he solved reflashing the bridge firmware, which probably had been corrupted.

Another option would be install Hassio on a different machine, recover the backup and see if it works, so I could exclude any failure with the RPI.
As an extreme attempt I’ll try repairing the devices, but it would be extremely annoying…

By the way, the most important thing would be prevent the problem to happen again in the future, so if I dont’ find the root cause all my work would be futile

Yesterday I set up a minimal Hassio installation on a old notebook; I connected the conbeeII stick, I installed the Deconz extension and imported the mesh configuration.
I had the same results as in the RPI, so there are some problem with the stick itself or with the configuration file

Regarding your question, how can I check the signal strength?