Welcome to the Twilight Zone - now here's the weirdest one I have seen yet!

This is the internal temperature of a Shelly Dimmer 2 relay with this exact configuration. It does bother me that the temp reaches 153 degrees F when the dimmer is on but in the current configuration that is the best that can be done and I live with it (I have tried LED’s and a bypass, I have tried diffferent bulbs, I have tried recalibarion, etc. etc. - the main ‘issue’ is that there is no neutral available). It typically drops to 100 degrees Fahrenheit when it’s turned off.

Every day sometime between 5:49:32 am and 5:49:45 am without fail, it reports one reading of 32 degrees F (freezing).

There are no automations taking place at that time and the light is always off then, typically we are asleep. WTH?

Any ideas?

Firmware bug, integration bug. Have you reported it to Shelly?

1 Like

No, I figured I’d paste it here and see what people say first…

Ok… so I now have upgraded to the latest HA…

Note the above problam was only with a Shelly Dimmer 2.

It went away but a similar problem which is worse now takes place with the temp readings for ALL of my shelly devices:

at about 4:10am the readings all stop for all of the devices. Restartng HA does resolve the issue - until 4:10am the next morning.

I am pretty sure it is an issue with the integration because of the above as well as the fact that the current readings for the relays are all correct while the history does not get properly populated (until a HA restart).

1 Like

Thank you @Holdestmade

Actually, once the auto purging for the recorder is stopped, the problem comes back - and it is only with the Shelly Dimmer 2, no other Shelly devices that I own -


So I will log this as a separate issue and also reach out to shelly as well…

Yes, that looks like a different issue. Just a thought, as its exactly 32F and that is 0C, maybe the sensor is just registering a zero, ie unavailable ?

I just determined more information on this when looking into whatyoiu said. I had forgotten but I had set up an automation long ago that reboots every shelly device, 30 seconds apart one after the other, starting at 4:45am (which seemed to help with stability at some point in the past). I am pretty sure that there is a hiccup that when this unit reboots it registers, once, 32 degrees fahrenheit. It is still an issue and I wlll continue to pursue it as such with the integration issue and shelly issues logged witht he manuafacturer.