WEMO undiscoverable

I just started playing with HA last week and am working on adding different components. I recently purchased the WEMO light kit and am trying to connect it to HA. I have tried using the discovery component and the wemo component, but both result in a description.xml error.

I am running HA on a rpi2 and through a docker container for testing. Any suggestions on what I can do to get these integrated? As a side problem, I am also unable to get Plex to connect either.

16-05-11 00:56:20 pywemo.ssdp: Error fetching description at
16-05-11 01:01:25 netdisco.ssdp: Error fetching description at

How do you have it set up in your configuration.yaml file?

Also, Plex will only show up if you have a client currently connected to the Plex server when you startup HA at first. BTW, FireTV connected to Plex won’t count; it will show the component for the FireTV instead.

For the WEMO, I tried using the discovery and the WEMO components. I also tried to set the ip address. All methods returned the same errors in the log.

I didn’t know Plex would only show up if a client was connected at startup. I figured the component would only display in HA while a client was connected. Thanks.


Name of the location where Home Assistant is running

name: xxxxx

Location required to calculate the time the sun rises and sets

latitude: xxxxxxxxxx
longitude: xxxxxxx

C for Celsius, F for Fahrenheit

temperature_unit: F

Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time$

time_zone: xxxxxxxxxxxxxxxxxxx

Discover some devices automatically


Find WEMO devices


Show links to resources in log and frontend


Checks for available updates


View all events in a logbook


Enables support for tracking state changes over time.


Enables the frontend


Try adding the IP address of the wemo devices and see if it finds them

  - etc.

I tried that last night with the same response.




16-05-11 00:56:20 pywemo.ssdp: Error fetching description at
16-05-11 00:56:30 pywemo.ssdp: Error fetching description at
16-05-11 00:56:31 homeassistant.components.media_player.kodi: Unable to fetch kodi data
16-05-11 00:57:11 netdisco.ssdp: Error fetching description at
16-05-11 00:59:18 netdisco.ssdp: Error fetching description at
16-05-11 01:01:25 netdisco.ssdp: Error fetching description at

Not sure but it seems strange to me that you put in but the pywemo errors are from the locahost and another IP range…

Granted, I’m on WIn10 and so it’s probably different, but any errors I’ve ever gotten either had my actual IP of the HA host or one of the IP addresses on the same subnet. What are you running HA on?

Well I was playing with it on my RPI2, but I switched back over to the docker container and its working fine. I thought the switched would show up automatically, but I had to put them in a group in order for them to show on the dashboard. Now I get to play with automation. YAY!.

Thanks for the suggestions.

Oh! I assumed you had them in a group already. If you didn’t change the default_view though, they should have shown up in a group with all the switches. Not sure why that didn’t happen. Glad you got it working though.