What can I do to get an entity to be used? How to debug the communication?

Sorry about the title, but I have no other idea. :frowning:

I’ve installed ESPresense, I’ve meaning added 4 ESP32s and 4 devices sending BLE signals. For three or those devices, everything worked out nicely, but one is constantly refusing to work.

I have no idea, what I still could do. Is there anyone with more ideas compared to me?

Currently still in the configuration.yaml I have e.g. this:

  - platform: mqtt_room
    device_id: "iBeacon:ed98f1e7-3a55-4aa5-95c5-075be4a60c3e-100-1"
    name: "S22U_ip"
    state_topic: "espresense/rooms"
    timeout: 5
    away_timeout: 150

  - platform: mqtt_room
    device_id: "iBeacon:3887a6b2-3548-491e-bfd2-880c02519bd6-100-1"
    name: "S22U_tp"
    state_topic: "espresense/rooms"
    timeout: 5
    away_timeout: 150

The S22U_tp is working nicely, but the S22U_ip does not want to be recognized.

The ESP32s are talking to both devices as well:

I’ve changed the entries in the configuration.yaml ten times, I’ve renamed the S22U_ip device, I’ve purged the entities again (using dev-tools → service → recorder:purge), I’ve restarted the system, …

Now, I don’t know how to proceed. Any ideas? Thanks a lot.

Hmm, I just found out that I can use the MQTT Explorer to see, which components or entities are communicating with my MQTT server.
I can see my three known devices, but the fourth is not showing up in the list. Still the ESP is logging communication with this device.

What could possibly block this last device?

Solved. I’ve reinstalled the HA app on this device and now it works. I guess, there was something wrong concerning the username/pw, so the mqtt message was not getting accepted, but how have I been able to control the HA, if the user was not logged in?

Don’t know, but the issue is solved and my self talk is over.