What happened to my view? (Lights are no longer in their areas since 0.104)

I am using the automatically generated Lovelace view with my HA instance. This was working well because I had placed all of my devices into various areas and they were automatically grouped by area in the UI.

Last night I upgraded to 0.104 and this evening I noticed that all of my Hue lights have come out of the area cards and are on their own individual cards. The light control itself has changed from a simple toggle switch (which was really simple for areas with multiple lights) to a giant light bulb icon with a dimmer curved over the top of the bulb. It looks exactly like the picture from the blog post:

Is there a way to have Lovelace go back to the previous view? I realize that this is likely due to the new " Add a device to Lovelace" feature mentioned in this release but I can’t seem to find a way to configure which card the device uses without taking over my Lovelace view and I’ve really been enjoying the automatic grouping by area. It’s very slick.

This same thing happened to me. Have you figured out why yet?

Same here. I must say it’s very annoying.
I hope someone will have a solution soon.
I had my lights and switches combined into room ‘groups’ Only the switches are shown in the group.
All the lights are shown seperatly…
There is also an issue for this: https://github.com/home-assistant/home-assistant/issues/30881

For now I changed my default page to the states page.
It’s not the real solution but it looks far better now.
You need to click the last line on the page info. (see image below)

Not sure but due to breaking changes entities might have been recreated. You should add the new entities to areas or rooms again.

if using the auto generated groups, they are no longer available as per breaking changes

From github.
The issue is fixed in the next versiion 0.104.2

Just upgraded.
Issue is still there

Can’t see any mention of it in the release notes

It fixed for me but it didn’t happen right away. Directly after the upgrade I checked and the issue was still present. A few hours later I logged in and everything was exactly as it was before 0.104 was released.

My apologies to @woestric, it did work, but as you mentioned, not right away.


perhaps it hadn’t upgraded the frontend?

Does it take some time after the upgrade to do so? Any idea how long?

You normally get a message to upgrade the frontend after a few minutes. (although I don’t remember seeing one and I checked and I am on latest frontend. Maybe it’s auto-upgrading now)

Glad it is working now. Though I was just the messenger :wink:
Unfortunately I had a total crash with HA. I suspect due to a SD card error.
I could not revive it and backup was only on SD-card. So now I had to start all over again and I am now in the process of reconfiguring :face_with_raised_eyebrow:

Hope to see it all working again soon…

I feel your pain.

My rPi suffered that same fate around 12 months ago for the fourth time and at that point I’d had enough.

It was only with version 3.7 of HassOS that USB boot was enabled so I’m now running Hassio off a USB HDD attached to my rPi.

No issues so far :crossed_fingers:

Good luck !