What is required for zigbee2mqtt

I want to install zigbee2mqtt, since I am having issues with zha and restarts.

What I plan to do:

Delete all devices from zha, uninstall zha.

Install Broker

Install Z2M in python virtual environment

Install Zigbee auto discovery in HA

Anything else I should take care of?

Also is it really required to install z2m with sudo, if I just install to a user folder?

What type of install do you have?

Both zigbee2mqtt and Mosquitto mqtt broker are available as addons.

I ran both ZHA and z2m side by side during my migration. Being able to migrate at my leisure and keep everything functional during the process was worth investment in the extra stick. I guess it depends on how many devices/automations you have in place.

I’m on hass os on a Pi and just used the z2m and mqtt add-ons.

I use Home Assistant Core in a python virtual environment. That’s why I prefer this installation as I can manage it myself.

Since I only have a few devices, I will do this with one stick, but thanks for the idea.

1 Like

As you did not detail them, are you sure that z2m+mqtt will not have these very same issues?
I run docker versions so not comparable it seems

Do yourself a favor and run both Zigbee2MQTT and Eclipse Mosquitto as containers (probably using docker-compose) and only the MQTT integration of HA to connect.

You mean instead of auto discovery?

No, instead of running z2m in a Python vEnv. Infact, I recommend anything to run in a container instead of a Python vEnv.

Not even aware, that you have to „install“ MQTT auto-discovery, just enable HA support in z2m and things work out of the box.

Second that, if you are a bit known to docker… take his proposal!

Except, docker support on macos is less then optimal.

Yes I have been there. That’s why I am running Core. And it is pretty flawless.

Docker doesn’t support USB devices on Mac. :crazy_face:

pfff… mac…another derilict from unix :slight_smile: … as lomg as you are happy

I am. :slight_smile:

But in that case I am not sure on which side the problem lies. Docker could support it - they just decided not to.

Ok, I installed Mosquito and zigbee2mqtt and it can connect to ConBee. I also set homeassistant to true in configuration.yaml.

But I don’t see MQTT in HA. I guess I am missing something here.

Zigbee2MQTT:info  2022-04-21 19:30:54: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'

Not making your life much easier but… I use this one to get all the details of my mqtt
MQTT Explorer | An all-round MQTT client that provides a structured topic overview (mqtt-explorer.com)

macOS is actually UNIX certified, as opposed to, say, Linux :stuck_out_tongue:

1 Like

Docker on macOS is running inside a virtual machine, I think that’s the main reason.

But what is needed on HA side?

Is it only the MQTT plugin? Where is the web interface (if there is one)?

You need MQTT Integration in HA and connect it to the running MQTT server.

Zigbee2mqtt’s web frontend must be enabled in it’s configuration file.

1 Like

It finally worked. So much better than zha.