What is UPnP/IGD in 0.8.0?

I just upgraded HA and it keeps telling me that I have a new component discovered.

UPnP/IGD. I don’t expose my HA outside of my local network so I have no desire to enable UPnP. How to I tell HA to disable this new component?

I don’t see this feature documented in the 0.80 upgrade docs.


If discovery is enabled, use the variable ignore so that it will not be discovered anymore.

Thanks! What is the correct setting to ignore? I don’t see upnp I the list of valid entries.

Try this one.


The ignore value is - igd


All this does is pull data from your router



It’s nice to have but I can’t really think of a way to use it?

Could probably use it to see if your internet is down and perform tasks.

I can’t think of one time my internet was down that it wasn’t caused by either a power outage or my router getting a push firmware update. So I really don’t see that use for it either :slight_smile: Might be useful in places where you pay for your usage otherwise not sure.

But lets say your router gets the firmware update and home assistant doesn’t reconnect. You can build an automation to detect that and restart home assistant after x minutes.

But I don’t need this to detect my router not connecting. I can just use a script with ping or one of many other ways to see the network is down. Actually I am not sure if this would even work using these sensors. I find sensors tend to keep their last known value when they don’t get updates. So I don’t think you would suddenly see the sent/received data go to zero. I think it would stick at last known value. I may be wrong on that but would have to test a lot more. It would help a lot if this feature had some documentation. I am sure the author had a use for it. They could share that use in the documentation. That would be nice :slight_smile:

It looks like it was just added to discovery recently, which is why you are seeing it now. Component has existed for quite some time, v0.18.0 to be exact. Here’s the documentations:

1 Like

This has started to be discovered again in 0.85.0 the same exclude value also works again in the discovery section of config yaml. I also noticed it can be configured to disable statistics in its own config section. I chose to ignore it from being discovered.

Is there a way to only pull certain sensors from the router? Like I only want kbytes send and kbytes received as a graph to track my internet usage. HA randomly pulls sensors so that depending on restart, some of the sensors are available and some are not. Next reboot they change. Not sure why but Id prefer to do away with the ones I dont need and just make sure it pulls the ones I do.

Anyone know of a way to explicitly set these sensors?

Are you sure they are coming from UPNP?

Yep, here’s the screenshot

And heres my config

  sensors: true
  local_ip: 192.168.1.xx # IP of Home Assistant

# Netgear Router Config
  - platform: netgear
    username: !secret router_username
    password: !secret router_password
    interval_seconds: 30
    consider_home: 180
      track_new_devices: true
      hide_if_away: true

why is it configured in configuration.yaml and in integrations? Typically that is one or the other, not both.

I just wanted to confirm (cause there is lot of obsolete infos on forums because of the developement) that

    - samsung_tv
    - igd

works and I don’t think there is any way to ignore just the router(s)