What is usb port for RFlink

As an absolute noob with HA I would like to add my RFlink.:

I ran ls /dev/tty* and got dev/devttyACM0 as result for my RFLINK
In the configuration file I added these lines
port: /dev/devttyACM0

Unfortunately I don’t get any reponse.

. What should the port address be then ?

I am running Hassbian on a raspberry 3

Thanks in advance

Edit : I think I found my fault portnumber should be :dev/ttyACM0 . But it still does not work, log says invalid config


you provided no detail about your platform. I have RPi 3 with Raspbian Stretch and using this configuration.yaml for RFLink:

  port: /dev/ttyACM0

You can also check device path by dmesg or ls /dev/tty*

You should check HASS config before restart:

I thiink I use the exact same code like yours. I use the Hassbian image file on a RPI 3.
I did not change anything further. So far I used Domoticz but think Home Assistant has more features. Little frustrating that I can not get the first thing to work. Configuraion was checked

Below the complete yaml configuration (replcaed # with // because of getting large fonts when using the # )
// Name of the location where Home Assistant is running
name: Home
// Location required to calculate the time the sun rises and sets
latitude: 53.2868
longitude: 6.3211
// Impacts weather/sunrise data (altitude above sea level in meters)
elevation: 0
// metric for Metric, imperial for Imperial
unit_system: metric
// Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
time_zone: Europe/Amsterdam
// Customization file
customize: !include customize.yaml

// Show links to resources in log and frontend

// Enables the frontend

// Enables configuration UI

// Uncomment this to add a password (recommended!)
// api_password: PASSWORD
// Uncomment this if you are using SSL/TLS, running in Docker container, etc.
// base_url: example.duckdns.org:8123

// Checks for available updates
// Note: This component will send some information about your system to
// the developers to assist with development of Home Assistant.
// For more information, please see:
// https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
// Optional, allows Home Assistant developers to focus on popular components.
// include_used_components: true

// Discover some devices automatically

// Allows you to issue voice commands from the frontend in enabled browsers

// Enables support for tracking state changes over time

// View all events in a logbook

// Track the sun

// Weather prediction

  • platform: yr

// Text to speech

  • platform: google

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

port: /dev/ttyACM0
wait_for_ack: False

// device_tracker:
// - platform: nmap_tracker
// hosts:

I am using RFlink sensors yet, so no experience with light / switches, but regarding docs here, they should be added automatically.

You can also try to enable debug logging of RFLink component in configuration.yaml:

  default: error
    rflink: debug
    homeassistant.components.rflink: debug

Then every RFLink command / packet will be logged to home-assistant.log in Home Assistant configuration folder

If you have custom group setup, you should add new devices to group config. They should be anway visible in States page:

Is it possible that is has something to do with syntax or indent’s
When I add your logger-code I cannot reach homeassistant anymore

I cannot find any information about syntax etc.

Edit: While playing with indent’s suddenly a lot of 433 Mhz device appear in the logging :smile:
So…next goal :insert switches

Allthough the syntax should be very simple when looking at the example, my sensors.yaml gives an error when adding devices.

This is my code :
– platform: yr
– platform: rflink
name: Regen tuin
sensor_type: rain_rate
When I remove the lines starting from devices: all sensor devices are added ,but with the odd names :frowning:

Because spaces are very important in YAML files, please post your config in code block which preserves spaces - begin with 4 standalone back tics on first line and end with same:

```` <- 4 back tics
config from yaml...
```` <- 4 back tics

You should see block in preview with monospace font

Slowly beginning to learn how the syntax in Yaml should look like.
Meanwhile I added 7 several different sensor_types with decent names.

Thank you for your help.