What is wrong with the iRobot integration?

Automatic retrieval of credentials (pressing home button until tone and wifi symbol blinking) failed for me. The failure message comes immediately after sending the confirmation that the home button was pressed. A timeout of 1 ms? Something must be wrong here.

2nd method:
Sucessfully got BLID and password via the scripts recommended by the integration’s documentation. Used both recommended methods, got the same credentials both times. So I guess they are correct. But when trying to configure the robot manually, the integration asks for the password but never for the BLID. The configuration breaks with a connection failure right after the password is sent to HA. Sure, how could it succeed with only half of the credentials? Something must be severely wrong here.

I successfully added my Roomba with the standard method (long-pressing home button) one time after a reboot of the robot and switching off all devices running the iRobot app. Worked until the next reboot of HA. Then the connection got lost again. Never showed up until then.

My hardware:

  • HA, standard docker image running on Synology (no supervisor)
  • older iRobot (no map), 6000 series if I remember correctly

Thank you for any help

Sven

It hasn’t worked for years, even today it’s broken.

I saw your other post claiming the integration is broken and should be removed. What’s broken about it? My two roombas work fine, one is a 690, the other is a 960. I can start/stop them and send them home and locate them. I get bin full status and battery level status as well. I also get the relative position of the 960. Just because it doesn’t work for you (which you haven’t even said what’s not working), doesn’t mean it’s broken for all. Sure I had some weirdness where I would have to either reboot the roomba because the credential seemed to have expired or just reload the integration in HA, but I’ve never had to fully remove and reset anything to get it working again. And even then, I only have to do this rarely, maybe once every 4 or so months.

Don’t make unfounded blanket statements. If you have specific errors or problems, then ask for help or better yet file a bug report on GitHub for the integration.

Bug reports are there, unanswered for years. There are ways to get around “most” of the issues depending on what model you have and what firmware you’re on, but listing this as supported for Home Assistant is a stretch. Homekit integrations work better and are maintained, worst case you need to use dorita980 to find credentials.

Waste your time lecturing elsewhere.

Most of those bug reports sitting idle are because very little information is provided to even start debugging. But again, the vast majority of users of the integration don’t experience any issues, so why should the integration be removed? You sound like someone that likes to complain a lot but contribute very little. Noted for the ignore.

I briefly looked into this when I was considering buying a Roomba a while ago (I ended up not buying one). This integration is based on the roombapy library, which looks like it was abandoned by its developer years ago. For the last two years, the only commits are automated dependency bumps and bdraco trying his best to keep the whole thing from falling apart with newer HA versions. It absolutely looks like it’s on life support and held together with duct tape.

1 Like

Logical and informed response.

I have a J7 and M6 cleaning my first floor (2200sqft) and am very happy . I did recently purchase a Roborock S7 MaxV to clean my basement (same sqft) and was not impressed with the mop combo. The integration works well, though.

Likely going to buy the same Roomba combo as on the first floor. On my second floor (2500sqft) I have an old Samsung Powerbot since it’s a low traffic area, but wouldn’t recommend it. That integrates via Smart Things also, no issue.