What the hell is going on with all that entity naming/renaming/friendlyname/registry

Sorry thats all so confusing… one example.

Because I like to “Life on the limit”, I tried to rename the entity for a simple xiaomi humidity sensor in the UI.
it called: sensor.humidity_158d0001714066 (friendly name is: Kira Luftfeuchtigkeit) not very usefull name. But I made a few automations and added this to groups for the UI.

Today I want to try the “rename my entity in the UI feature because we all hate the entity_registry.yaml” and I renamed sensor.humidity_158d0001714066 to sensor.kira_luftfeuchtigkeit.

And BAM it instantly disappeared from the UI…(ok because the name changed, but why the possibility to change name entity when it breaks everything???)

Ok because I’m super clever I want to rename I back to the old fantastic name so I went to the developer tools.
But sadly the little settings Icon is missing on the renamed entity ID so its no way to rename this because the entity_registry is gone for normal users…

and WHY is the friendly name now the OLD entity name…I dont get it.

Sorry I think this hole new entity/registry/zwave/rename/friendlyname/UI renaming need to be a little bit more userfriendly

1 Like

I feel your pain…

And it seems the ones who can address the issues people have with it are non-receptive and/or non-responsive.


I think it might be better to just use customize.yaml to modify the name of the sensor. I haven’t personally tried using the front-end or entity_registry.yaml

It should still be there, it’s just that you have to update the entity id in the group you had it in as well.

I have a multisensor zwave device which I set up with friendly names but didn’t bother updating the entity IDs as it was the only one. I recently added another multisensor and things got confusing so I updated the entity ids of all the sensors associated with the existing device. This removed the sensors from all the groups I had them in as the groups still had the old entity names. I used the find and replace function in my text editor to quickly fix the sensor entity IDs in my groups.yaml file, reloaded the groups in the configuration panel and all was well again.

1 Like

The friendly name won’t change automatically, because the (sensible) assumption is that if you wanted it change you’d change it. However, the lack of a cog for renaming isn’t good, and I’d recommend you raise an issue since that’s a bug.

yes you can do this. But on many situations you have to deal with the entity ID and then is a useful name necessary. And again. The possibility is there in the UI and it breaks Groups/customizens/automations/scripts/databases…etc

Yes I have to update the groups and every other place of use. And its not possible to rename it back because the settings ICON is gone for this “new” entity.

But the friendly name changed, as you can see in my first post the friendly name also change to the old entity name.

In my opinion, the entity registry must contain all informations for the place of use/customizen and changed them automatically…or its completely useless. I dont know if this is even possible.

Then raise an issue

Yeah that cog disappearing is not right.

Thanks for reply.

Ok I made an issue on github.
But its not only this little bug in the UI. I think this the whole entity thing needs to be overthinked.:weary:

I tried a bit more. I renamed the entity with one uppercase (sensor.kira_Luftbefeuchtigkeit) This has caused problems.
I renamed the entity in the core.entity_registry and my problems are fixed!

Don’t use upper case characters in entity ids.

1 Like

@kolossboss Did you solve your problem? I have same issue in version 0.91.4.
Did you raise an issue?

The basic problem is still there. Renaming an entity breaks everything that used this entity.

One if my problems are solved by removing uppercase in the entity ID.

after changing the name in the entity registry, you must change the name in all locations of your YAML. You may need to add the device back into the interface depending on the mode of lovelace that you are using.

My problem is that I am adding new z-wave devices, I have not manually configure this devices in any way, I just added them as new z-wave device and I am unable to rename the nodes. I have to go to core.entity_registry to rename them, at least that is the only way I have been able to do so for a while. A few weeks ago I was able, I am pretty sure I messed up something that is creating the problem.

It’s a bug in 0.91 - expect it to be fixed in 0.92

Until then Configuration -> Entity Registry

1 Like

Thanks. Did not know this other way to get there.

Also, make sure you don’t confuse the terminology…

renaming a zwave “node” is completely different than renaming an “entity_id” that gets created by the zwave node.

To rename the entire zwave node you need to use the zwave.rename_node service. to rename entity_id’s then you need to use the cog (once it gets re-implemented) or in the entity registry in the meantime.

Thanks for the info. I did understand the difference and yes I just wanted to rename friendly name and entity id. However, I had not realized I could rename z-wave node, that is pretty interesting to me to fill in gaps between nodes.