When I added SSL to HA, the connection to InfluxDB stopped working

I just got me a Google Home Mini. To be able to use that in HA I had to enable SSL in my HA. Took a few hours but now it’s running.
Almost… The connection to InfluxDB has stopped.
My HA runs on a Pi (xx.xx.xx.30) and my InfluxDB runs on main main Ubuntu server (xx.xx.xx.50)
Do I have to re-configure my InfluxDB to be able to send data from my HA (x.30) to my InfluxDB(x.50)?
This is my configuraion.yaml

  ssl_certificate: !secret path_ssl_certificate
  ssl_key: !secret path_ssl_key

  host: xx.xx.xx.50
  ssl: true
  verify_ssl: true

What do I need to do on the xx.50-side?

// Tommy

Is SSL also enabled on your influxdb server? Seems like you’re telling HA that your ifDB server is running SSL as well. I haven’t used influx but my assumption would be that homeassistant “reaches out” to the database server and wouldn’t need to be reconfigured to continue working after SSL is enabled (on HA)