When my python libraries are too new

Dear all:

I am encountering the following error when I upgraded to latest Home Assistant. My Home Assistant is install via Hassbian.

myusps 1.2.2 has requirement requests==2.12.4, but you'll have requests 2.19.1 which is incompatible.
python-jose-cryptodome 1.3.2 has requirement pycryptodome<3.4.0,>=3.3.1, but you'll have pycryptodome 3.5.1 which is incompatible.
pyowm 2.8.0 has requirement requests<2.19,>=2.18.2, but you'll have requests 2.19.1 which is incompatible.

In all cases, it seems to do with the fact that my installed python libraries (which I didn’t install it myself) is too new.

What should I do?



Ditto. Hassbian.

these errors should be safe to ignore, are you experiencing any issues?

They are not ignorable, they prevent some dependencies being loaded, eg DHT sensor not found on hass.io

Home Assistant is constantly adding features to it. The error I got SEEMS to effect on features which I am not using yet.

So, to answer your question. So far, it hasn’t effect me yet. Then again, I am struggling with home assistant with all the stuff I have right now and don’t have to bandwidth to explore any of the new features.

Things like myusps is something I would LIKE to use eventually.

I have no idea python-jose-cryptodome is for.

open weather is something I really like to have it around…eventually.

I will ignore it for now… i am hoping this error will “magically” fixed itself next time I update hass :slight_smile:

I h