When using transitions turned off lights will first show previous color

Tags: #<Tag:0x00007f73b95b7ac8> #<Tag:0x00007f73b95b7910>

Hi,

I’ve been busy migrating my HUE Zigbee lamps to HA via Zigbee2Mqtt and I basically want to mimic my previous HUE setup. While setting everything up I found out that the transitions work a bit differently when turning on a lamp. I did some research and I’m quite confident the issue lies in HA’s way of transitioning.

What the heck explanation:

  1. I have a scene which (for this example) turn the lamps to a green color with a transition of 1,5s
  2. I turn off the scene/light
  3. I turn on a different scene which turns the lights to white with a transition of 1.5s

The weird thing is that at step 3 the lights turn on starting with green then transition to white. I would have expected it to turn on dimmed white and then transition to bright white.

Visual explanation:
image

I think it can be solved by first change the color of the lamp before turning it on for the transition.

As far as I know this is a limitation of the light technology. @123 knows more about this topic. I have the same behavious with my Hue bulbs and this can’t be changed as far as I know.

But if it is a light technology issue, wouldn’t Hue then also have this issue?

That’s a behavior I have noticed with my Philips Hue Color bulbs. Upon turning on, they remember their last state (color, brightness, etc). So if the last state was green at 100%, if you send a command to turn on red at 75%, the result will be a momentary display of green (its previous state) before it assumes the new state (red).

As far as I know, there’s no way to “preload” a color (or brightness) before turning on the light. In other words, send “red at 75%” to the bulb while it is off (effectively making it the new "previous state’). So when you do turn on the light, it immediately becomes red at 75%. However, none of this possible with Hue bulbs. FWIW, it is possible with LIFX bulbs (according to the LIFX integration’s documentation).

1 Like

That’s probably some functionality that is proprietary to their software.

Maybe @Koenkk knows?

It sounds like two separate commands are sent: 1) turn on, 2) set the color to white. Instead, a single command should be sent: 1) turn on to white.

This is a platform specific issue, LIFX actually had the same problem long ago: https://github.com/home-assistant/core/issues/2472

1 Like