Where are component dependencies installed on the file system?


I’ve tried for days to figure this out but didn’t succeed. Where on the filesystem does HA (I am running HA OS) install Python dependencies that my custom component requires (in my case the enocean pip package)? I have set up SSH access, i.e. I have access to the filesystem, but I did not find the package in any of the usual locations.


Did you search in the HA container?

I looked at the guide but I don’t even manage to disable protection mode…

This is what I see when I try to run the docker command:

[core-ssh ~]$ ha docker exec -it homeassistant bash
Error: unknown shorthand flag: 'i' in -it
  ha docker [command]

  docker, do


  ha docker info
  ha docker registries

Available Commands:
  info        Shows information about the host docker backend
  registries  Manage private OCI docker registry

  -h, --help   help for docker

Global Flags:
      --api-token string   Home Assistant Supervisor API token
      --config string      Optional config file (default is $HOME/.homeassistant.yaml)
      --endpoint string    Endpoint for Home Assistant Supervisor (default is 'supervisor')
      --log-level string   Log level (defaults to Warn)
      --no-progress        Disable the progress spinner
      --raw-json           Output raw JSON from the API

Use "ha docker [command] --help" for more information about a command.

FATA[0000] Error while executing rootCmd: unknown shorthand flag: 'i' in -it

How did you setup SSH access?
The command is:

docker exec -it homeassistant bash

without ha

The guide is about the addon-ssh

and the protection mode has to be disabled for the docker command to work.

1 Like

This worked - thanks a lot. I overlooked that this is the other SSH add-on…