Where is Open Z-Wave in Hass.io?

I’m trying to troubleshoot an issue where my new Leviton switches are being listed as “unknown” (thread here) even though they’ve been in Open Z-Wave for awhile now.

How can I tell what version of Open Z-Wave my Hass.io (v 0.60.1) is using? Where are those files? I’m not super familiar with docker so I’ve poked around a bit but I haven’t been able to find them.

Open configuration tab/pane.

Click on Z-Wave.

Click on ‘Refresh’ in the Log section. It should be the first line. like this:

2018-01-14 22:56:20.796 Always, OpenZwave Version 1.4.2586 Starting Up

Thanks, I didn’t think to look in the log. v1.4.2586

I see from the tags in GitHub that Open Z-Wave 1.4 was originally released in January 2016, but I can’t find any indication what the “2586” part of the version number means. There’s no tags beyond the major releases on the repo.

Where are the Open Z-Wave files located in Hass.io?

You cannot access them.

Maybe this can help


My devices are in the OZW database, and have been in their master code branch for over 7 months. What I can’t figure out is if those definitions are in the version of OZW that Hass.io is using (v1.4.2586) because there’s no tag for that specific version on Github and there’s apparently no way to see the OZW files being utilized by Hass.io. My growing suspicion is that HA isn’t including those device profiles, because they weren’t incorporated into 1.4.2586, but I haven’t been able to figure out how to verify that.

I’m having the same issue that the GE 14287 Z-Wave fan controller is showing up as unknown. According to previous posts I should be able to add this to the manufacturer_specific.xml file. I cannot locate the manufacturer_specific.xml file, and I don’t see the GE 14287 listed on http://www.openzwave.com/device-database. Is there a way to add this to either one or access the files it’s using? Hass.io is still Linux, the files/data are stored somewhere.

I haven’t tried this, but try setting the config_path in your zwave options to somewhere you can access under /share, then add your manufacturer specific files there?

Oh, how could you change the port settings in config then? also when you setup zwave you cannot setup it again. So how to remove the first setup?

what ports are you talking about?

is there some reason you aren’t using the zwave configuration in the GUI of Home Assistant?

No reason. I tried it but dit not work. I think i should reinstall Hass.

I use Hassio, i tried to install Zwave and i got Zwave under Hardware tab but no devices. So i think the Usb port is not good.
I look under system hardware:


Next i tried to set in the row

  usb_path: /dev/ttyAMA0
I got config error.
Even tried it with  /dev/tty/ACM0   no luck