Where is the "Remove Failed Node" Option For Z-Wave Devices?

Hello Everyone,

I’m on Home Assistant 0.84.6 and trying to remove a dead z-wave node and at one point I remember seeing a: Remove Failed Node option in the: Z-Wave Node Management but it no longer appears to be an option:

Was this removed at one point and if so, how do I go about removing dead z-wave nodes now?

Should be higher up in network management, remove node. Don’t think there is a remove failed node itself anymore.

You might have to update state manual as described in the last section here: https://www.home-assistant.io/docs/z-wave/adding/

  1. Go to the States menu under Developer tools in the Home Assistant frontend
  2. Click on the name of the zwave. entity you want to remove
  3. At the top, edit the JSON attributes to replace false with true for “is_failed”: false, so that it reads “is_failed”: true,
  4. Click Set State
  5. Go to the Z-Wave control panel in the Home Assistant frontend
  6. Click the Remove Failed Node button in the Z-Wave Network Management card
  7. The device will now be removed, but that won’t show until you restart Home Assistant

Thanks to everyone that replied! I tried your method and receive this error after clicking: “Set State”

Click on the sensor in the table below, that will populate the text box with the current state in Jason format. Then find the is_failed entry and change false to true.

Looks like this:

Is there something I’m doing wrong because nothing ever populates no matter which Z-Wave device I select. I’m running Home Assistant on RPi:

Home Assistant 0.84.6

core-ssh:~# cat /etc/os-release
NAME="Alpine Linux"
PRETTY_NAME="Alpine Linux v3.8"

For example, this is the Z-Wave switch for the kitchen lights which is paired and works just fine, I’ve waited a few minutes and nothing ever populates:


You have to select it by clicking the hyperlink in the table you see when scrolling down, not by picking in the drop down menu

Okay, now I understand what those links do. I previously clicked on them and did not realize they populated those fields because I had scrolled way down the page, clicked on a device and nothing happened so I thought it was a dead link! And what’s the point of selecting an Entity in the dropdown list if it does not populate the State Attributes? This sounds like a UI issue and really should be corrected as it was confusing to a new user like myself so I’m sure it might confuse others. Also, step 1 from the “Remove Failed Node” is mis-leading as it implies to click on the zwave device from the dropdown list. Think about it, the drop down list is at the top of the page and all the devices are there so why would one look anywhere else?

  1. Click on the name of the zwave. entity you want to remove

It’s not very specific but now I understand it actually means to click on the device LINK from the Filter Entities section.

Regardless, thanks for the help!

I have found that sometimes I have to do the “remove failed node” and restart HA twice before it is really gone.

1 Like

Can confirm. Current process appears to be (with a truely dead node):

  1. Restart
  2. Select Node in Configuration->Z-Wave. New options appear, 1 being “Remove Failed Node”
  3. Select Remove Failed Node. If you’re tailing the z-wave log, you’ll notice nothing happens in the log.
  4. Restart.
  5. Select Node in Configuration->Z-Wave.
  6. Select Remove Failed Node. If you’re tailing the z-wave log, you’ll notice that there is logs about removing node.
1 Like

thanks for the procedure … I manage to remove a dead node as follows:

  1. Developer Tools
  2. States Menu
  3. Select the zwave in the Entity box
  4. In the JSON attributes; find “is_failed”: false, and change it to “is_failed”: true,
  5. Save State
  6. Configuration -> Z-Wave
  7. Select Node
  8. Remove Failed Node
  9. Restart HA from Server Controls
1 Like

After upgrading to hass 0.115.1 my z-wave stopped working. I downgraded with backup and realized that I also had a lot of dead z-wave nodes. When I tried to delete this nodes as mentioned in the docs https://www.home-assistant.io/docs/z-wave/adding#removing-devices the logs told me that this isn’t possible due to a remove process is running.
As I read here in the forum (sorry for not linking) decided to shutdown the host and disconnect the z-wave controller from usb-port. Then I pluged in the controller, started the host and tried once again to remove the failed node over the UI. This time it worked out of the box… Reboot and the node with dozens of entities has gone.
Upgrade to 0.115.1 worked also.
Maybe check also the the zwcfg_xxxxxxxxxxx.xml in config folder.