Where is the ui-lovelace.yaml file?

I have installed HAC in hassio and the instructions for one of the sutom cards states:

When installed, this will be located in ‘/config/www/community/dual-thermostat’ , you still need to add it to your lovelace configuration (‘ui-lovelace.yaml’ or the raw UI config editor) .

- url: /community_plugin/dual-thermostat/dual-thermostat.js
  type: js

Where is the ui-lovelace.yaml located though?

In one of your views in Lovelace, click the overflow menu in the upper right (three dots), click Configure UI, click the dots again, then click Raw config editor

4 Likes

In your configuration folder if you’re using YAML mode.

Most folks won’t be, so you’ll use the raw UI config editor.

Adding this to ehe raw config editor:

  - url: /community_plugin/dual-thermostat/dual-thermostat.js
    type: js

resulted in a menu entry called ‘unnamed view’ with no contents:

You need to add those lines under resources: in the raw config editor. Create that line if it doesn’t exist.

1 Like

Have a look at this guide

5 Likes

I’ve added the resource to the raw config editor:

but how do I add the card, as it’s not listed:

The UI editor doesn’t support custom cards.

How would I add the custom card then?

Back to that raw editor, you’ll have to add the card manually.

Or click “manual card” and enter the card config there. The UI editor doesn’t create a new button for custom cards.

2 Likes

The example given on the deleopers site is:

cards:
  - type: custom:dual-thermostat
    name: Downstairs
    entities:
      - entity: climate.downstairs_cool
        type: cool
      - entity: climate.downstairs_heat
        type: heat
    fan_control: true
    min_slider: 60
    max_slider: 80

but adding this to the raw editor results in:
Screenshot%20from%202019-11-30%2014-22-05

You can paste what’s below cards: by clicking “manual card” in the UI and pasting there. Remove the first hyphen too.

But anyway, that error is saying you have more than one cards: in the YAML for that view, which isn’t valid.

It does, you just have to use the “manual card” option at the bottom.

1 Like

Thanks, but entering it as a manual card results in a never ending rotating circle.

1 Like

Adding it to the raw editor results in no entry in the UI:

    badges: []
    cards:
      - type: 'custom:dual-thermostat'
        name: Downstairs
        entities:
          - entity: climate.downstairs_heat
            type: heat
        fan_control: false
        min_slider: 10
        max_slider: 24

Hi,
did you manage to get the card in?
It seems, that I am on the same programming level :slight_smile:

I just installed HACS and I am trying now the same .
Your solution would help a lot.

Best regards,
Jörg

3 Likes

https://www.home-assistant.io/lovelace/dashboards-and-views

It appears that Dashboards > Resources gets automagically populated with the right URL now so I guess the instructions on many repos are now outdated?

image

@kcd I found this because I was searching for a way to use the dual-gauge-card.js (which hasn’t been updated in four years on GitHub). I have tried putting into the configuration with only the name dual-gauge-card.js, with /www/dual-gauge-card.js, ./www/dual-gauge-card.js and the full path /home/pi/Docker-Compose/Homeassistant/Data/www//dual-gauge-card.js and nothing works. I still get “Custom element doesn’t excist”. The file is there, as taken from the GitHub page, but I can’t understand why I can’t get it into the setup. Would you please shed some light over that, if you can?