Where is the Z-Wave config stored?

The zwcfg_xxxxxxx.xml file seems to list all wave nodes.
The article Z-Wave Devices - Adding and Removing explains how to go about adding and removing nodes. Will I accomplish the same if deleting the node from the .xml file?
Can I make changes directly in the zwcfg_xxxxxxx.xml file - presuming I know the correct syntax for xml?

That file is a cache only. Adding or removing entries from it won’t change the devices that communicate with the Z-Wave controller (since that’s held in the controller itself).

Thank you, @Tinkerer.
I have yet to find the ultimate way to re-arrange/clean up all these nodes that was configured, but for some reason has stopped responding (not “sleeping”) and need to be re-attached to the zw network.

Any suggestions? - ´cause its starting to look messy, and it´s a pain to reconnect 20 nodes now and then.

It seems to only affect the battery driven devices, and for now I’ve been waiting 48 hours for them to report back, I have been “waking” them by pressing the button on the device, both once, and three consecutive times (like when pairing) without getting them reconnected.

The missing nodes are not reported dead, either.
They just vanished from the Gui and controller page in HA.

  • Can I get into the controller-setup? Is that what Open ZWave Control Panel do?
  • Can I rearrange, eg. put new nodes into an abandoned (previously dead) node ID —> No Node connected as Node 10, new Node added automatically as Node 20. Can I then assign this new node to be recognized as node 10?
  1. You don’t need the control panel - the things you need are built into HA
  2. You can’t renumber nodes

Vanishing nodes isn’t normal, and suggests an underlying problem - maybe an issue with the Z-Wave stick itself, or an indication you’re running on Docker/alternative Hass.io install and didn’t uninstall modemmanager.

Could you elaborate on uninstalling the modemmanager?
You mean from Ubuntu or OS X?

EDIT: I found this thread on the issue

As far as I know only affects Ubuntu, I’m not sure even for Debian but I’m almost sure it doesn’t affect OS X.

So it might be I have to uninstall modemmanager. I am not even sure if that is in the build I was installing.

I was using this disk image; VMDK (VMWare Workstation), found here.
But again: My VirtualMachine is defined as Ubuntu.
Then I converted it to .vdi and enabled dynamic disk space.

You guys surely have lots of experience with this, I just try to figure things out, and this error that could be part of a faulty z-wave stick or something else is really strange.
Iw I would try another z-wave stick, is there a way I can transfer the settings to a new stick?

If you used an image to install Hass.io, you don’t have that problem.

If it’s the same brand, you can use the software from the manufacturer to back up and restore the stick.

1 Like

Probably stating the obvious here, but you’ve run the “Heal Network” command if you’re moving nodes around?

Sure :slight_smile:

Aeotec seems to only provide Windows and linux backup software.
To fully understand the setup: Is the zwawe config only stored within the controller stick? Which means the regular HA snapshot won’t provide a backup of my zwave configuration?

The zwave network configuration as in the nodes and their node numbers, yes.

It won’t hold the node configurations such as the node numbers of the devices, correct.

Thank you for the explanation.
Is there any way to back the nodes and node numbers up through HA, or a plugin?
… or a software running on OS X?

No you have to use the backup utility from the stick manufacturer.

If you’re using Aeotec sticks I belive they might have a application you can use I’m not 100% sure.

No, the only way to back up the stick is to use the software from the manufacturer.

1 Like

I have the same question: where is the Z-Wave config stored? I have configured Z-Wave in Home assistant through the Configuration/Integrations method, NOT by adding some lines into my configuration.yaml file. However, I would like to enable polling for some devices. This is possible to do through the configuration.yaml, but since I have configured Z-Wave through the Integrations menu, it has saved the configuration somewhere else. nut I don’t know where…

If you’re wanting to configure polling in the UI (Z-Wave control panel), you’ll still need to add a zwave entry to configuration.yaml. Mine looks like this:

  device_config: !include zwave_device_config.yaml

The UI will save the poll settings to the zwave_device_config.yaml file.

Thank you!

Unfortunately, that’s the point exactly, that I do not have a zwave_device_config.yaml file… what is supposed to create it?

It’s created via the GUI, add the lines to your configuration.yaml then, after restarting HA, in the Zwave panel select your node, then the entity from the list and you will get a polling option.

Thanks! But if I add the lines to the configuration.yaml and the zwave_device_config.yaml does not exist, it’s saying that the configuration.yaml is invalid… which is true. So I don’t dare to restart it like that, maybe it won’t start at all.