Where to find older img file for RPi 3b+


My 0.84.4 HA system was running fine until the SD card simply died. I had taken snapshots, but couldn’t find them on the RPi system. Thinking I would find it someday, I never got to it. But I managed to save my configuration, automation, scripts files. I had Alexa tts running perfectly and all-in-all, it did everything I needed.

I took an image of the bad SD card but putting it on to a new SD card showed lots of filesystem errors. I’ve been searching for the original .img file containing Hassio 0.84 to start over again, but I can’t find it by hassio version number. Releases are numbered differently

So I looked at dates of releases and since it was around early December 2018 that I built it, I looked for releases of that era. I found Release 1.13 but the Hassio version is 1.8 or something. I imaged the card and brought it up but I can’t get samba to work not will it accept my configuration files. It will be a long road again to rebuild what I had and could use some help.

Can someone point me to the RPi_3 image that will get me 0.84 hassio? (I hope I have these Release vs Hassio version terminology correct. I was hoping to find some documentation that outlines releases and the hassio version within so I can download the correct release.)

I’m not one to try to jump ahead to the current release because I typically leave a running system alone unless something needs fixing. Any help you can lend is greatly appreciated.
Thanks much.

Assuming Hassio.

Load the latest image. Then you can up/downgrade to any version using this command in the hassio CLI (SSH console, i.e add the SSH addon first):

hassio homeassistant update --version=x.y.z

Then copy your config files across ( add the SAMBA addon if you don’t want to do this via the CLI).

Then get yourself up to date by reading the breaking changes in each release since then. Amend your config as required and update (one version at a time if needs be).

Then automate snapshots and copying them off the SD card regularly. Search the forums for ways to do this. There’s a popular way to send them to Google Drive.

The image is not directly related to the version of HassIO. When you boot it the first time it will try and run updates on the host OS (HassOS) and will pull in the latest hassio images. In fact, the img doesn’t contain hassio at all. It contains the OS and pulls in the 2 images on first boot.

1 Like

Thanks. I did try to down rev using the update command to 0.84.4 but it got errors late in the process and now it’s in a bad way. It won’t come up and run homeassistant. I’ll give it another try tomorrow when I can get back to it. The RPi is running and has a network address on eth0. The errors are visible on the hdmi video screen. The usb keyboard also works fine. Maybe I’ll just rerun the update cmd again to see what happens.

I tried once again to acccess homeassistant using local ip address:8123 and I get connection refused error. So I went into the RPi console and reran the homeassistant update --version 0.84.4 command and it returned “Incorrect usage: Flag provided but not defined: --version”. I tried with one dash and got the same error, so I used no dashes and it said Ok.

But nothing happens. I re-imaged the SD card with 1.13 image file and started from scratch. After a while it comes up and I can get in and add a user, etc. So I go back to the RPi keyboard and login as root and execute the same command. it says ‘Ok’ and the info command says I’m running 1.13.

So what am I doing wrong (or out of order?)


You left out the =

oops - sorry. When I typed it into the hassio cli I used the =. sign. I’m assuming that I don’t need any dashes because when I do I get the error about flag provided. unfortunately, I can’t cut and paste the command because I use one monitor that I have to switch between this windows system and the RPi console.

I’ve been repeating this sequence a mind numbing number of times. I’m just now loading the rpi3_1.0.img file to see if that gets me any closer.

Any idea what is supposed to happen when the command is executed besides returning ‘ok’?

I’ve already stated that the image file has nothing to do with the version of hassio. HassOS will update itself and hassio will pull in the latest version of home assistant

Yes, I understand that flamingm0e. It’s just that I am attempting to do the downgrade to 0.84.4 once hassio is running from the image that was loaded. The command does not seem to work on the 1.13 image, so I took a chance and tried an earlier image in case it only knows how to upgrade to a higher rev not lower. Just a shot that proved to be futile anyway.

I would like to restore all my automations and lovelace interface pages, scripts, etc before moving on. Any suggestions on how to do that are appreciated.


Hi - one more question. Are you saying that no matter which release I load, it will always go out to get the latest release of Home Assistant? So even f I sart with 2.12 image I should be able to revert to 0.84.4?

I’ve been unable to get the 1.13 image to load version 84.4 and I also can’t get Samba to run on it. Not sure what is going on. Although it took me weeks to get it to where it was running what I needed, I’m just hesitating and avoiding rebuilding from scratch using the newest version but as time passes, I may be better off. I just didn’t have a few more weeks to spare and I’m dragging my feet looking for an easier (shorter) route.

Thanks for the support.


You should, but I’m curious why you are going through so much trouble to load such an old version of Home Assistant.

You shouldn’t have to rebuild from scratch. Just fix your configuration errors one at a time.

So just install the newest version and adjust your configuration for the latest version. You’re overcomplicating this.

Thanks. I was starting to think the same thing. So wish me luck as I start this recreation. Just to sanity check,

  1. I’m going to use the 2.12 image file, bring up home assistant,
  2. edit the configuration.yaml file and replace it’s contents with my much longer configuration.yaml, (fix issues) and
  3. do the same with automations, scripts, etc.
    Unfortunately I did not save my lovelace.yaml file and I’m sure a few other things. My duckdns too.
    Sound like the right order?

duckdns is easy. Just fill in your information.

I would recommend just using the GUI for editing your lovelace.

pretty much.

Sounds like a plan. It’s up running it’s initial install. Now for the fun part.
I appreciate the support.