Where to put gtasks-card.js


this issue is getting me mad.
I downloaded the gtasks-card.js file and followed the steps to configure inside HA.

I added the resources through the HA gui choosing “Java script module” as type and the following url:


which I created ad-hoc since it didn’t exist.

Then I restarted HA but in the dashboard I can’t see this card, and if I try to add a manual card, when I write:

type: custom:gtasks-card

I get:

Why I have this (damned) issue? I didn’t understand… which is wrong?

Do you have card tools installed?

This /local/community/gtasks-card/gtasks-card.js should be



Even if I knew that /config/www is /local , I tried to modify in /local/www/… but nothing changed.

your lovelace url resource should be /hacsfiles/gtasks-card/gtasks-card.js

Tried again and didn’t resolve.
But I noticed that the difference between the resources added automatically and the one I added manually is a tag that in gtasks doesn’t appear:

Mabye do I have to check the rights of gtasks-card directory (give a chmod 777 …)?