Where's my file

I created a log file in Node-Red don’t know where it placed it. I know it did because I read the file back in. My issue is I am not a linux…yet… I don’t know how to search for the file in HA. I tried to find it in Configurator with no luck. There is no way to search using that. In all the videos online the just change to some kind of file explorer.

Is there a file explorer I can use in HA?

I tried Putty but having connection issues

There are two add-on’s for HassIO that may help. One is the Samba Share, which lets you connect to some of the key file systems over SMB/CIFS (ie Windows file shares). I’m not sure where the Node-Red add-on keeps its files, but you could try “config” or “add-ons”.

The other good add-on to install is the SSH server , which will give you putty or ssh access to the hassio container (not the base OS for the host). I know the recommendation is to set up ssh keys, but you an also set up password access, when you configure the add-on. This is for the user “root”. This is how I do it, make sure you include the quotes.

  "authorized_keys": [],
  "password": "your-password-here"

Thanks… with SSH I finally got putty working.
I used the find command and did not find the file. At this point I think it is out of scope of this HA since it’s Node-Red now… At least I think it is out of scope.
Thank’s again


Every add-on has it’s own directory for it’s configurations and whatever files you put on there.

Inside the add-ons share should be a node-red directory that contains the file.

Inside node-red, it’s probably /data but HA cannot see that directory, because they are different docker containers, running with their own configurations and mapped directories.

Still can’t find it. I got everything working that everybody mentioned so far.

you can always use portainer (hass.io addon) and then run a console in the node-red container and find it that way. That will be your best bed I’d say.