Which linux OS?

I am thinking of moving from a Raspberry Pi install to a laptop desktop setup. I want to setup a file server and as it will be on 24/7 it makes since to move my setup onto this new machine.

I have a few spare laptops and like the idea of the built in battery backup and being able to use it for additional things (ie file server). The built in keyboard, mouse and screen will be nice sometimes too.

Question is what Linux variant is anyone using? I have a daily driver mint machine and have used Ubuntu in the past for various projects so those would be my initial go to.

Also other than GPIO dependent components (RF transmitter, Relays and DHT22 sensors) everything else should be transferable I assume.

I am a newbie with home assistant but not with Linux. Raspbian is Debian and Ubuntu isn’t too far off the Debian mark. I’d say you wouldn’t have a problem with Debian or Ubuntu.

I am running my Home Assistant on my Mac Mini server where my LogitechMediaServer is however I’m running MQTT on my Ubuntuserver and will probably move Home Assistant over at some point once I get a more complete configuration in my home.

If I went with Debian I think I’d go with Stable and not testing though.

1 Like

Thanks for your input.

I have been using Ubuntu 16 with no issues.

1 Like

I’m using Lite Linux.

I use Ubuntu server, no problems.

1 Like

I’ve been considering this myself lately. I have a spare PC that was running my Plex server but I recently bought a ShieldTV (OMG, Plex is soooo much better on this!) so I’m thinking of decommissioning it. It’s a home built but with pretty standard components.

My major worry is device support and drivers. Should I be that concerned? Last time I tried installing linux before the Pi was decades ago. If I boot off the DVD, will it give me a good indication of what is supported or not?

Only real issue I have had drivers wise is USB wireless devices. However if you buy one that is natively supported it’s not an issue.

I’ve run a lot of different systems with unbuntu, mint, arch and Debian and never have needed to install a driver on a hard wired system. This is mostly older hardware 2-5 years old or a raspberry pi.

Some Linux distorts will boot off a USB drive and run (but not save your config) if you want to just test things.

If you have a spare hard drive drop it in your PC and try it out. Install is pretty quick to get up and running from my experience. It often takes longer to download the ISO then to do the actual install.

I may try this tonight. I’ll try to document my findings as I make the trasitition in this thread.

I just grabbed the Ubuntu 16 ISO and burned it. I’m going to try booting it off one of my desktops that has a monitor connected (the Plex server is ‘headless’) and see what happens.

I’m guess that the only thing I’d have to really be concerned about is the ZStick, but since that’s working on a Pi now I should be ok. Otherwise I have no major issues with using a wired keyboard and mouse if it comes down to it. :slight_smile:

Ubuntu 16. Works great.

I run Ubuntu 16 server and am a fan of the desktop version as well (run it dual-boot on my laptop and SP4). Although I originally ran HASS on a Pi3, I was running Ubuntu to serve Zoneminder & file server on a old laptop for a while as I had the same thought of built-in battery back-up. This worked fairly well other than Zoneminder being a little more processor intense for the aged laptop. HASS does not appear to be to needy nor would I expect a file server to be most of the time unless you are serving to multiple destinations at the same time and even then this would probably be more of a HD issue than the processor.

So long as your processor is relatively new (1-4 years old) and has at least 4GB Ram your should be good to go. Mint would require a little less resources than Ubuntu Desktop, but Ubuntu Server would probably run just as well as a headless or non-GUI interface - And the community support is very strong for this version.

On a side note, while I was running HASS on my Pi3, I used the item below to provide battery back-up. It would run the Pi for hours uninterrupted.


Thanks all. Decided to just try it out on my mint install. Well see how it goes.

1 Like

Ok took an old Dell D630 (core 2 duo cpu, 5400 rpm hard drive) and install HA using the v env instructions.

Install went pretty quick, would have gone quicker with a wired connection to the internet. From there started HA and it worked well. Decided to move my config over to test it and everything came up except for Nmap and icloud. Nmap needed something installed which is documented on the Nmap component page and icloud just needed to re-write the config file in the icloud folder. Otherwise its up and running.

Going to let it run like this for a bit and see if all my automations and components function but so far it looks like a smooth transition.

Reboots and viewing the logbook are 1000% times faster. Reboots are seconds instead of a 30sec - 1 min and the log book is only a few seconds to load too. Hopefully those changes stick.


Raspbian is a cut down version of Debian so it makes sense to run Debian as your server OS. I have Debian running with an SSD as the HA server. HA is super fast and especially since I use FFMpeg to stream cameras I have here. A Raspberry pie would just shit itself with 60+ devices under this environment.

Good luck

How you install HA on ubuntu.
I use a tutorial from HA site and problem is with components.

Not sure wht you mean exactly, but as far as I recall the install was very smooth. As far as I recall, I used these instructions:

1 Like

Yes i install to with this instructions.
Then not work avahi for iOS component.
Then not work record component (sql error)
After install a mysql nothing work.

Is pain in the … install on other distro than raspbian

I had no problems whatsoever, and it continues to work perfectly.

You should add what distro you’re using just for completeness. I’ve personally seen HA running on a number of other distros throughout the forums.

I’m running HA (VirtualEnv) on Ubuntu 16.04.2 LTS with no problems on a RaspberryPi 3.