Whisper and assist language

Hello everyone,

New to home assistant and trying to set up a local voice assistant. I followed the tutorial:

I followed the steps, the only difference is that I set my native language (which is not English) to whisper, piper,… Everything went smoothly but.

The problem is that assist understands everything I write, BUT when I talk to the microphone in my native language it tries to translate whatever I say in English and therefore writes nonsense and nothing work.

Do you know how to solve this issue?

Note my HA UI is in English.


Is this because Whisper is setup and running in English?

Assume you have Whisper running in an add on, check the add-on config? I run it externally as

Ok I fired up HaOS and installed Whisper for you… Here is where the setting is

Amazing thank you for the quick reply!!! I thought setting the right language when setting up the voice assistant was enough!

Any advice on the best model to use on a NUC? Is tiny-int 8 enough?

Have a great day!

No problem, welcome to the community, please be kind to Mark the post which best provides the solution so it helps others

Re best model, as the intents in HA are simple tiny-int8 is currently satisfactory. I use it as it’s fast enough even on slow machines like mine

You have a great day too :+1: