Why can't emulated Hue work with OnHub or Google Home?

So i have an OnHub and planning on getting the Google Home. About a month ago, the OnHub got an update that lets it control the Philips hue. So if my Amazon echo dot can identify my emulated hue, why cant google products do the same?

I think @brusc mentioned in the comments of his latest video it is because GH requires that you have a login at the Philllips cloud.

Yea just looked at that video. I really hope its an easy fix/patch to the emulated hue code that would make it work.

I just picked up a Google Home this morning, stuck with IFTTT to HA to Wink 2 for complicated automations. Very slow. Would love to take IFTTT out of the mix to cut down on response time. If HA could do local commands to the Wink 2, I would be one happy camper. Will have to investigate the IFTTT new Applets some more as it does look like multiple actions can now be taken on a single trigger…anyways, now I’m rambling…

1 Like

So I ended up picking one up yesterday and even though IFTTT is slower on the google home than local control through emulated hue, Google home is still faster than my echo when using IFTTT. Also it makes it so much more natural to say “Ok Google I’m going to bed” than it did saying " Alexa, trigger night mode".

Only complaint is that I cant seem to get the Google Home to cast to my MiBox 4k, keeps telling me it can only cast to “Chromecast supported devices and Chromecast integrated TVs” .

1 Like

@nshak Are you using Maker post messages in IFTTT? I haven’t been able to get them to work for some reason. I can send a Post via Postman successfully to HA, but IFTTT has been failing me.

Yea I’m using Maker. One thing that got me at first was that I used http instead of https for the URL since my HASS has SSL enabled. maybe that’s whats failing on your end?

Well I guess there is some hope, found this video on youtube showing an Alexa HA bridge using OpenHAB working with Google Home. Not sure if the OpenHAB bridge is based on the same code we use or not, but at least I know now its possible to get it running without having to wait for google to release the API in 2017!


@iantrich I am using the Maker channel and it is working very well! Here is how I am triggering my bedtime scene:

URL = https://my-url.org/api/services/scene/turn_on?api_password=XXXXXXX
Method = Post
Content Type = application/json
Body = {“entity_id”: “scene.bed_time”}

The guy in the video is using https://github.com/bwssytems/ha-bridge. Which is awesome and there is tons of material on how to get it working with Home Assistant. It will take out the IFTTT step in my current setup and hopefully speed up response time.

1 Like

Excellent! Looks like I’ll be ordering a home now - already using Ha-Bridge for Alexa.

1 Like

@BarryHampants Do you find Ha-Bridge to be more responsive than the emulated Hue bridge in HA? Trying to decide if I should go to the trouble of setting up ha-bridge or just wait till we get Google Home to be supported in HA.

Ha bridge is quite easy to set up. Emulated Hue never really worked for me, almost always fails on boot 19/20 for me and hasn’t worked once since I got my dots. I have a shell_command permissions error within my install though so may be nothing to do with Emulated Hue. Will try a fresh install when I have time.

The great thing about Ha Bridge is being able to rename actions when I find Alexa has some sort of conflict with my naming scheme, and only adding stuff I want to add. You can run both so give it a shot.

Here you go.

Yea I’ve tried to get HA bridge working for weeks now but no luck. I agree that Installing and setting up everything is really easy. However, there is a problem with HA bridge working with SSL certificates from LetsEncrypt. Every time I try to connect to HASS via HA bridge I get this error:

Error on calling url to change device state: https://xxxxx.dyndns.org/api/services/homeassistant/turn_on?api_password=xxxx

@ih8gates has had an issue open on this for about a month now with no luck. I hope it get resolved soon :confused:
Issue link: Trouble connecting to server using LetsEncrypt SSL certificate

BWS is helping me diagnose my issue. It looks like I’ve got a path issue to my local SSL cert. I’m working through how to fix this. I’ll report back when I get it working.


Please do; this is why I didn’t bother setting up HA-Bridge. Now that I have Google Home in the mix I’d like to revisit it but I also use Let’s Encrypt.


You are right, I forgot about that - this was why I went back to running without a certificate. I started looking at an alternative to lets encypt but things got way past my understanding very quickly. I’ll have to wait for someone else to work this out.

I am on a Pi and tried to set it up last night, but got errors when trying to boot it. Looking at issues on the repo I found that it need Raspbian full, not Lite which I have, to work. Not sure what dependencies are missing.

I used the all in one installer, initially, but that was overkill as I’m not using a zwave stick or mqtt. So I’ll probably re-image Raspbian full and get HA-bridge running on it.

I’m running under the same setup - AIO and Raspbian Jessie full version. As far as I know the only dependency I needed was Java which is in the instructions from @jbardi linked above.

Are you using the BWS version - there’s two Ha-Bridge’s out there that I know of.

Do you have anything using port 80? That is the default port since version 3.2.

Also - did you start it? You will need to set it to launch on boot too. The instruction on the Git have a directory a bit wrong for where it installed on the Pi for me - see here for differences.