Why can't I select device/entity when using WLED Set Effect service

Whenever I call the WLED Set Effect service from within an Automation, I am unable to choose which device or entity I want to apply the effect to.

Did you try to do the same from the developer console? Please do cache reset shift+F5 and then try

Just tried from the developer console and it’s exactly the same, even after a Shift+F5

Are you able to see the device in the device tab of developer console?
Also instead of UI, please try the yaml method in developer console

I can see the device on the States tab of the Developer Tools if that’s what you mean…?

Not tried yaml method yet but somebody on Reddit has advised that this worked for them, so might try that soon.

It must be a bug. But I am able to control the wled with yaml mode like this.

service: wled.effect
  effect: police
  intensity: 100
  palette: Tiamat
  speed: 150
  entity_id: light.wled

After copying this in yaml mode, if you go back to UI mode, you can see the entity selected there.

Yeah, that works for me as well so that should suffice for now - thanks.

1 Like