Why does Big Timer say its gonna trigger in 2 hours?

I thought, or at least I am trying, to set it up to only trigger on the first day of the month, 15 minutes after midnight.

So here in MN, USA its currently Dec 1, 21:48. And big timer is saying its going to trigger at 0:15 on Dec 2. Why??



Seems like a wrong timezone to me. Is that maybe because of Daylight Savings Time or the lack thereof?
Currently you should be on GMT -6,right?

You can check your TimeZone in the Node Red Config:

Time zone configuration

The addon will use the configured time zone of the underlying operating system. If this is incorrect (for example with the Home Assistant Operating System it will be UTC), this can be configured in the /config/node-red/settings.js file.

To do so, open the file with a text editor and add the following above the module.exports = { line.

process.env.TZ = "America/Toronto";

The time zone will need to reflect your environment.

Save the file and restart the Node-RED add-on.

Still, I was under the impression that the Latitute and Longitude Settings automatically choose the correct timezone in big timer. Anyway worth a try.

A wrong time zone should only move the start time with the difference. This is moved to the next day.

I have never used big timer before, but I could not get it to work as I would expect when I played with it.
The included days should be possible to write as 1 in days and 1-12 in months, but this make no difference.
I also tried to play with the exclude days by typing 2-31 in days and 1-12 in months, but alas no luck.

I tried the timezone thing, but still same thing. I changed the day to 2, (since 0:15 of day 2 has already passed), and it says it will now trigger on (0:15 of day 3)

I suppose following that logic then, if I set it to the last day of the previous month, it should trigger on 0:15 of the following day? Which would bring it to day 1 of new month.

That would only make sense if a bad implementation of the 12H notation was affecting it, since that notation first change day at 01:00, but if that was the case, then setting the start time to 01:15 would reveal the bug.