Why does Google Assistant always turn on my KNX air conditioner on heat mode?

Home Assistant has been trying to roast me all summer xD
I have a KNX air conditioner linked to HASS and HASS linked to Google Assistant via Nabu casa. Whenever I say “Ok Google, turn on the air conditioner” (ot climate or whatever) it always goes from off mode into heat mode. I don’t know if it’s a Google Assistant issue, a KNX library issue or HASS issue, but the command is just “turn on”, so It should remain in its previous setting when powered on, just as it would when turned on via remote controller. I made an automation to change the mode whenever it goes into heat mode but it’s just a dirty fix. Help appreciated.
Thanks and keep up the great job!

This should be resolved with HA 0.115. It was a bug in the knx climate integration.

1 Like

I don’t think it was a bug with just KNX I have a zwave thermostat and say “hey google turn on the cooler” always defaults to heat mode. It used to turn on the cooler by setting the thermostat to cool.

Have the same issue now , how can I fix it?

try saying “set the thermostat to cool” thats been working fine for me :slight_smile: