Why does Google Assistant says that temperature is off?

Tags: #<Tag:0x00007f3f1b338db0>

I have exposed 3 temperature sensors (1 Z-Wave and 2 ESPHome sensors) through Nabu Case Google Assistant integration (Manage Entities). It works - when I ask for the temperature, it answers. But why it also says “the temperature is off”? What does it mean? How can I turn on or off the temperature? Did I do something wrong in the sensor configuration?

It normally does that when you expose it a climate device like an aircon or heater. What it is saying is the current state of the aircon/heater, and what the internal temperature is.

‘The garden’ is one of these temperature sensors?

How are you exposing just a temperature sensor?

Garden is the “room”, the sensor is called “temperature outside - an alias in Google, otherwise it has the name in Czech language” (but if I ask Google about temperature outside, she will default to the local weather forecast, so I use the “room” name, it works).
Now I understand - It is not a climate device, it is a standard sensor:


This is how I expose it on Nabu Casa
image

I’ve not seen that before for sensors, looking at the Google API, there is no such thing as a thermometer or sensor. I wonder if this thinks its an thermostat.

https://developers.google.com/actions/smarthome/guides/

That would explain it. In that case, lucky me :).

It would be nice if I could control the temperature outside from Hassio though :slight_smile:

Are you on the latest version of Home assistant?

Yes. I think @callifo explained that well. Google API does not have a thermometer device, so Nabu Casa smartly linked that to a thermostat device, that also measures temperature but also turns the heating on and off. So it is saying the heating is off. Never mind, better than nothing.

The google API does allow for a climate device which cannot be controlled, i.e. a climate sensor. See ‘queryOnlyTemperatureSetting’ on this page:

https://developers.google.com/actions/smarthome/traits/temperaturesetting

From what I can see in the source code the google assistant component correctly incorporates this so I think this is either:

  1. Despite google allowing this option they still return an off message.
  2. Nabu casa does something differently?

I haven’t set up a temperature sensor but can do so. Will try it out over the next few days. (I don’t use Nabu Casa)

1 Like