Why has my interface slowed on what used to be a fast system?

I appreciate this is a vague problem, with lots of similar past questions in the forum. I’ve searched, tried lots of suggestions and still not been able to solve this, so thought I’d post for help…

Basically the problem is that my front end (both web and Android app) has become progressively slower and slower, but also quite inconsistent. Clicking between pages on a dashboard or even sometimes in settings/config can take 10-20 seconds, but at other times it’s very fast. Using devices (eg switching a scene on) in Lovelace also sometimes takes 10-20 seconds. Rebooting sometimes seems to help but again, it’s inconsistent, and it’s slower far more often than it’s not. I had a low-spec Amazon Fire tablet where the slowdown really first became noticeable, but it’s also now noticeable on a current-gen smartphone using the Android app, and even on the direct web front end on a PC.

Other than keeping things updated, I’ve not made any significant changes in probably a year. I do have quite a busy setup with multiple addons and integrations, around 20-30 Zigbee devices via a ConBee2 and deCONZ, and at least 50 Zwave devices via an Aeotec stick and Zwave JS. I also run 6 Unifi Protect cameras with low res RTSP streams on one of my Lovelace pages. All of this used to run quite happily, and I could interact with Lovelace fairly speedily on any of the devices I used.

I run HAOS on an Intel NUC, with fairly decent specs: it’s a 10th gen i3 with 8GB RAM and a 120GB M2 SSD. It has a wired connection. Processor and RAM utilisation stay low; processor usually hovers around 6-8%.

Versions:

Home Assistant 2023.1.2
Supervisor 2022.12.1
Operating System 9.4
Frontend 20230104.0 - latest

I run MariaDB, recorder does keep a lot but my DB stays around about a gig and has a commit interval of 30.

I’m not sure what to look for in my logs, and although there are usually a fair few errors, I can’t see anything that sounds like it could be causing the slowdown.

What else can I look at to try and troubleshoot this? Any tips or ideas much appreciated!

I had a similar issue with the Android companion app a while ago. I found that clearing the app’s cached data fixed the problem.

Thanks for the tip - tried this and it does seem to improve things, but only for a day or so! Was it the same for you?

My improvement seems to be longer term.

If clearing the cached date produces a temporary improvement then we may be looking at the right area. How about try uninstalling and reinstalling the companion app.

I have this issue on the android companion app.

It feels like the android app goes to a crawl, but in a browser and on my POE displays with fully kiosk it’s not an issue. Odroid n2+ with about 40 integrations and 3000 entities, always sitting at 2-8% CPU load.

As the other poster mentioned, clearing cache in the app seems to work for a short time until it doesn’t.

The thing that seems to cause it, at least for me was having location accuracy for the app set to high accuracy. Now I just leave it as the default, and haven’t had any issues with it becoming slower than molasses running down a stick in -40f.

1 Like

Thanks for the suggestions! I run the android app on a tablet in the house also, which has location updates completely disabled. The tablet used to be an Amazon Fire HD, which was slow but useable. I noticed the slowdown on that first, so treated myself to a Xiaomi Pad 5 off eBay with MUCH better specs. Location is still disabled on it, but the slowdown has just got worse and worse, to the point where when I first use the tablet in the morning sometimes it is completely unuseable (takes longer to switch tab in a Lovelace panel than it takes me to make a filter coffee)

I’ve also tried disabling location on my phone’s Android app, and it doesn’t seem to help.

Interestingly, I am starting to really notice lag on the web interface too now.

Anyone have any other ideas? I would hate to have to completely reinstall as it would take days and days to recreate my setup, and I don’t even know for sure if that would fix things as I don’t know what the issue is…

Has no-one else experienced this?

I’m now at the point where I have to force stop the app and clear the cache at least daily on each device as they become unusably slow. They’re all fast devices, HA is running on a powerful system, and it was absolutely fine for ages before this.

Tearing my hair trying to find the cause. I’ve gone through pretty much every addon, reset/changed my database, tried simpler lovelace dashboards etc – still can’t fix it! Feels like the only option at this point is a complete reinstall without using a backup. With my mess of zwave and zigbee devices, automations, scripts etc, it would be days of work and the thought makes me want to cry :stuck_out_tongue: