Why is automation not triggering?

This automation runs long time without problems, but now it does not trigger. It should trigger every time the state changes to “true”. Works for month but now it´s broken???

The sensor is updating his state correct but automation is not triggering, was there a change in automations for hass i did not see?

alias: Wenn Szene Check nichts aktiv -> scene.Keine Szene gewählt
hide_entity: true
  - platform: state
    entity_id: sensor.scene_check_nothing_active
    state: 'true'
  service: input_select.select_option
    entity_id: input_select.scene_select
    option: "Keine Szene gewählt"

The usual suspect is whatever you last changed - what’s changed since it last worked?

Have you checked that sensor.scene_check_nothing_active still changes to true when it should?

There are multiple sensor.scene_check_xxxxxxxxxx and they all change immediately like they should. But the automations that should update the input_select to a specific option are not working. Sometimes they do sometimes not. All i did in the last weeks was update of hass. The automations have not changed.

What does your log show?

@Tinkerer seems to be a caching bug of my server connection. The things i tried never get their way to the server. After restarting the whole machine it´s working again. No idea what that was.