Why is my Hass so unstable?

Hello all,

I hope you all had a great start into 2024. Currently I have some problems with my installation which is really frustrating.

I have a Proxmox node with the latest PVE-Version running. I use a lot of your LXC-Container but only the Hass-Installation makes me wonder.

From time to time (sometimes once per day or once per week/month) I cannot connect to my HASS-Instance:

If I check the Proxmox-WebUi everything seems fine:

The VM makes a Backup every 24h firstly I used the stop method. After some time I switched to snapshot this helped a little bit. I am now quite lost and I don’t know which things are the problem on this VM. The VM has 6GB of ram and 2 cores assigned which is more than enough (Hass is really snappy). The issue above is fixeable with a full reboot of the Vm.

The Proxmox node is running fine - all other LXC / VMs are running totally fine!.

Now coming to my current problem:

This is only fixeable with a full reset of the vm which is really annoying and I can’t imagine what can cause such a behaviour.

Please help me to get HASS stable.

Maybe you should find a “Proxmox Forum” , As Proxmox has nothing to do with HomeAssistant, beside when it’s used to run HA in a VM

PS: Or show some logs from HA, which could indicate whether you have problems with HA

@boheme61 … Which logs? The device is not online and it’s impossible to get logs at this point.

Do you want the logs before that happen?

Your picture above shows that HA is up and running !

Why dont you try to “TYPE” something in the HA-console “which seems fine”

start with " --help "

I will try to re-create this behaviour. From my understanding the second pictures shows that something is crashed.

1 the RED error IS not coming from HA
2. The log-file ( as well as the RED Error … I Have no idea from where you get this

That’s why my initially Commend, Try a ProxmoxForum

A quick search would have given you this amongst other postings:


1 Like

Apple did not even pop-up in my mind :smile:, have been avoiding everything related to apple products since early Millennium, actually when they launched OS X 10.0 , which could be the only positive they did, around that time

PLEASE read the first post CAREFULLY.
The second issue is not related to Apple!!!

“It’s always DNS”

The error message provided is a failure of the browser or client resolver to successfully resolve the name being connected to.

This isn’t HA, and it might not be Proxmox either, but you’ll need to check your DNS server and ensure there’s a record for the hostname you’re attempting to access. If you’re entirely reliant on the .local domain namespace and that’s the thing that’s failing, look at your network and how it handles mDNS/Bonjour.


Latest is not a version.

Please stop shouting.

And please please stop posting pictures of text. Very bad form.

1 Like

:slightly_smiling_face: which is in a mixed environment, mDNS with MAC, Linux and most likely also a Windows Machine involved, is not “trivial”

But as Nick mention, there is a lack of HA logfiles, and no mention what or where the logfile-pic comes from, or what he assume/think it indicates

I doubt it would be fairly simple to guide OP to “penetrate” possible mDNS issues, as he is not even familiar with HA-CLI, and/or still haven’t been able to retrieve logfiles from HA

So let’s start step by step.

The second pic is from the Proxmox-Console as well as the first one. But with the difference that the HA cli is not available at this point…

The log files are only accessible if the cli or the webui is working. If not HOW should I get the logs? Please tell me if I don’t know a method.

The mdns issue is only sporadically - as well as the second issue that the vm crashes somehow.

Please tell me what more details you need?

Here is the Proxmox version: Virtual Environment 8.0.9

The MDNS issue is a seperate thing - today it worked fine. I can send you all the log files you want the instance is running and working.

The logs should be available after reboot, named .log1 and so on I think?

No, the first pic appears to come from a browser. I’ll work on the basis that you are referring to the third and second pictures.

Which console are they from? Proxmox os or the hassos vm? The second pic seems to be from the vm. But the third is not obvious. I’ll assume the vm.

When you get the third pic crash, can you ssh into the vm? That is the obvious way to get logs.

How did you install the hassos vm? tteck’s script is the only way I have done it.

What do you get from googling the error messages?

What did the proxmox forums say?

Nope not possible. The vm is dead.

Here are the information you requested:

Install-Method: Tteck script
Console pictures: All of them are taken from the WebUI (Proxmox->Console)

  1. Picture is from HA Companion app
  2. Picture is from the Console accessed via ProxmoxWebUi
  3. Picture the same as mentioned in 2.

Regarding the first Message I will try to do the fixes which I found online. Lets focus on the crashing

I checked the files and I can’t find any logs before 02.01.2024. I can restore the backup and try to get them. Which other information you need?
I didn’t post in the Proxmox posting - I don’t like crossposting.

Re the second photo - you say the “VM is dead”, but have you tried typing anything into the console? Even “hello”?

The console looks alive to me, but it’s just a static image so it could be frozen I guess.

Right, i guess you also read the log-pic carefully your self

It’s from an OS, which i don’t know (doo to your ways of presenting your use-case), the “audit” there mentioning something about “subj=unconfined key” … Prior to that you’ll notice the “command”, which lead you to /runc … in other words Container Handling … which i don’t know, as you haven’t “Spec” your environment either, I.e, add-onns, integrations etc. ( if it’s HA’s OS )

PS: The “crash” you experienced could then be caused by … what ever … " ha host update ", " ha core update ", " ha supervisor update " Should fix the “Native Default Parts”

If you still have issues, you have to dig into your add-ons, integrations, customization, and your imagination in regards which of these factors could cause the experienced behavior … And also try to “separate” Common Network related issues, even thou it might be related/caused by the same …

I will write here if I can recreate this behaviour.

Don’t, atleast not before you have gone through your logfiles, you have host, core and supervisor in the UI ( And also available through the CLI ! , Beside you also have logfiles in ALL your ADD-Ons !, and there is the home-assistant.log and home-assistant.log.1 And .fault … in your config (homeassistant) folder
Do it now, do it after a crash (your definition) , and do it after a restart.

And if you don’t take the opportunity, to update host, core supervisor and all your add-ons, re-download your integrations and check the bunch of logfiles after this , you are basically requesting help/assistance upon neglective behavior