Why is my transition not working via Node-Red?


i have a turn_on node for my Ikea Tradfri RGB bulb with the following Data output:

The Debug shows:

But i can´t get the transition to work.
On another lamp, the transition works, but not with this one. Do i have to specify anything ?

Glad for your help :slight_smile:

Hi, it would be best if you could share the flow.

Hey, how do i do that? I dont know, where i can get the “code”.

You need to select all the nodes of the follow. This can be done by pressing shift button and clicking on any of the node of the flow. Then CTRL+E. This will open up a window with the code. Just select all and copy. Then paste it here between ```

My flow:
[{"id":"5d1278d1.1ca3d8","type":"inject","z":"b0b3b768.6cfe28","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":230,"y":820,"wires":[["eb52e864.4e1588"]]},{"id":"eb52e864.4e1588","type":"api-call-service","z":"b0b3b768.6cfe28","name":"Licht Studiotisch","server":"1a33ac7a.3d8894","version":1,"debugenabled":false,"service_domain":"light","service":"toggle","entityId":"light.tz3000_dbou1ap4_ts0505a_level_light_color_on_off","data":"{\"transition\":5}","dataType":"jsonata","mergecontext":"","output_location":"payload","output_location_type":"msg","mustacheAltTags":false,"x":630,"y":820,"wires":[[]]},{"id":"1a33ac7a.3d8894","type":"server","name":"Home Assistant","legacy":false,"addon":true,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":false,"cacheJson":true}]

Try this code

[{"id":"5d1278d1.1ca3d8","type":"inject","z":"51045e07.bbf87","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":200,"y":1180,"wires":[["eb52e864.4e1588"]]},{"id":"eb52e864.4e1588","type":"api-call-service","z":"51045e07.bbf87","name":"Licht Studiotisch","server":"1a33ac7a.3d8894","version":1,"debugenabled":false,"service_domain":"light","service":"toggle","entityId":"light.tz3000_dbou1ap4_ts0505a_level_light_color_on_off","data":"{\"transition\":\"5\"}","dataType":"json","mergecontext":"","output_location":"payload","output_location_type":"msg","mustacheAltTags":false,"x":600,"y":1180,"wires":[[]]},{"id":"1a33ac7a.3d8894","type":"server","name":"Home Assistant","legacy":false,"addon":true,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":false,"cacheJson":true}]

You first copy it and go to nodered then CTRL+I, paste the code in window and import, then deploy and try

1 Like

What a easy workflow btw!

Thanks for your help, but it did not change anything. Tried the “” before, even with all sorts of brackets.

But what happens now is: when injecting the lights turns on with a slow fade of 2-3 seconds. Tried to change it to 100 but it stays with the slow fade, just when turning on.

Can you share the flow of the light which you said is working according to what you want. I can compare them

There we have a problem, i did not expect.
I swear, yesterday i got it running with with different transition timings. And my girl saw it too!
The flow i showed, is with the same light. Both are doing the same sh** now.
Restarted node-red and HA.

With transition-timing 0 the transition is completely off. From 1 to x its more or less 2.5 secs.
Whats wrong with that thing?

I´ll try that now on any light i have and share my results. Maybe its a global problem.

Check if the transition in wled UI is working? I have checked my device and the transition works fine.We can check it with developer console.
Go to developer console in the side bar. Then go to service.
Select the service light.toggle . select the entity and in the data window copy and paste this.

brightness: 500
transition: 10
entity_id: light.tz3000_dbou1ap4_ts0505a_level_light_color_on_off

What is that? sorry :smiley:

Sorry for the confusion. The node-red flow works, but it turns the light just on 20 % or so.

EDIT: now Web UI and Node-Red doing the same thing, but the UI Fader works as master for the brightness. But no transition either.

We can adjust brightness.Try this

[{"id":"5d1278d1.1ca3d8","type":"inject","z":"51045e07.bbf87","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":140,"y":120,"wires":[["eb52e864.4e1588"]]},{"id":"eb52e864.4e1588","type":"api-call-service","z":"51045e07.bbf87","name":"Licht Studiotisch","server":"1a33ac7a.3d8894","version":1,"debugenabled":false,"service_domain":"light","service":"toggle","entityId":"light.tz3000_dbou1ap4_ts0505a_level_light_color_on_off","data":"{\"transition\":\"5\",\"brightness\":\"500\"}","dataType":"json","mergecontext":"","output_location":"payload","output_location_type":"msg","mustacheAltTags":false,"x":540,"y":120,"wires":[[]]},{"id":"1a33ac7a.3d8894","type":"server","name":"Home Assistant","legacy":false,"addon":true,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":false,"cacheJson":true}]

Brightness works.

1 Like

Hope the issue is sorted. if anything let us know. Just FYI, you can use automations in HA for simple things. It also works great.

Brightness works, but transition does not work. So i´m still looking for a solution.
When i do an automation via HA its the same problem. Just tried that 5 minutes ago.

Where can i look to check if something with HA is going wrong?

Did you try this?
Also go the Wled UI by going to the ip address of the light and check if the transition there works.
If you need any more pointer, please do ask

I have tried transition with my lights and its working

1 Like

Okay i tried that but i got the same result. The transition is 2.5 secs or so.
I also tried the developer console as you said and got the same result.
There is no specific Webiface for the light, bc its integrated via a zigbee network.
In the Lovelace UI from HomeAssistant i get no other result as above.
I wish there was a direct debug of the light or so, so that i can see anything.

just restart the light and try. wled will have a web Interface. It will be in the light ip address. If this doesnot load, the light is not properly connected.

reached my 22 posts on day one :smiley:

Ok, i investigated the problem further and it seems, that specific LIDL and IKEA lights won´t work with transition automation. Maybe my mind was bad, when remembering that i worked the other day, or something other is going on.

There is no ip address for the light, at least i dont know about it.
But i restarted the lights manually with the switch and it didn´t change anything.

So i´m clueless again…