Why is the documentation about Google Home integration so bad and confusing?

I’ve tried following the docs, but information is missing, and links are jumping about, it’s really not well written.
Ok, so I managed to find out where the “project_id: YOUR_PROJECT_ID” that is supposed to be added to the configuration.yaml comes from, why isn’t that explained, it’s really not obvious???
Next line the “api_key: YOUR_API_KEY”, that looks like it’s a completely different component that has NOT been mentioned before, why introduce that there??? This is a mix between bad documentation and explanation on how to implement, which is absolutely not the same.
So I created a Homegraph API, and entered that.
I also managed to get the domains exposed.
So now I jump back up in the documentation (this is really messy), and now it says I should use the google home app (forgets to mention ‘on your phone’, might be obvious to some, but apparently not all), and then I’m stuck, I can see the testapp (no mention on how to rename that anywhere), and if I try to add it, I get sent back to the home assistant login page, but I’m not logged in, it just cycles back to the login, no matter if I have my MFA active or not.
Sigh, I know this is OS, but it sure reaks of ‘use our cloud service’ since the docs are so poor.
I have tried out the cloud, and that works fine, but I really dislike paying a monthly fee.

Well, if you don’t want to pay. How about contributing some time to the community to tidy up some of the docs now you’ve gone through the pain?


Have you thought that google may have changed their end also and the docs don’t reflect that?

As mentioned, you should now be in a place to update the docs for the bits you have confirmed working


That is absolutely true, and I wouldn’t mind doing that, I’ve done that so much in other projects already, but as I don’t have a working setup, I am not the person for doing that at the moment.
I don’t mind paying, that’s not the point, I don’t want to pay monthly, a once-off is ok, but running expenses is something I really don’t like, I have way too much of that already.

It’s a community project so if you see a problem, update the docs. That’s the one thing everyone can do.

So did you get it working or not? If not, did Yu make sure you enabled testing/simulation in the Google Console?

I’m well aware it’s a community project, but bad docs are worse than no docs. And I don’t mind contributing in whatever small way I can do it, I’ve done so numerous times, even for commercial projects.
I just made it work a few seconds ago. It was the API key that was the key, I believe the settings for that is the problem. I will go and rewrite the documentation for the integration, and hopefully make it more understandable, and when done so, I will find out how to upload it to the page as a new version.

You don’t upload new versions. Click on EDIT this page in the top right corner of every page and edit it and submit a PR. That’s how we do it here.

1 Like

Gotcha, thankyou.

So if you haven’t gotten your devices linked try 2 things (I had to do both of these)

  1. if you have a shortcut to HA on your phone’s homescreen, delete it.
  2. clear your phone’s browser cache

I had the same loop until I did that but since you’re seeing your test app you’ve mostly done the hard part; I won’t disagree it’s confusing, but working with google’s very advanced dev tools is confusing unto itself

1 Like