Why is this one Aqara ZigBee device not showing on HomeKit? All others are

Here is my setup: Aqara device → ConBee II → HomeAssistant → HomeKit
Every Aqara device I own shows in the Home app, except for one. There is one Aqara switch (“remote”) that is visible in Deconz, in HomeAssistant but it doesn’t make it to HomeKit. I have removed it from and added it again to Deconz. I’ve restarted HomeAssistant and the Apple HomePod mini that serves as HomeKit hub a few times. I don’t know how to troubleshoot beyond this point.

I might be asking this question in the wrong forum. Let me know if it’s best to post somewhere else.

I would be very grateful if someone could direct me on troubleshooting steps (even basic ones) or maybe point me to another forum category…

Did you reach the 100 devices limit ?

I don’t think so. 5 cameras & doorbells, 1 door, 4 hubs & bridges, 1 lock, 13 sensors. That’s it. I’m not sure how to best count devices in Homekit.
Thank you for your response!

Solved: These ZigBee devices were surfaced to HomeKit via Homebridge, not HomeAssistant. I restarted Homebridge and it worked right away.