Why the heck can't I configure Zwave delay and polling from the frontend?

Tags: #<Tag:0x00007f739b3cc1c8>

This seems obvious, if you’re going to move a core component from YAML configuration to UI configuration, there should be a way to set all the properties of that integration.

Is there some assumption that if you’re using the UI that all of your devices are magically compliant with the latest z-wave properties?

If I want to go back to YAML configuration, how do i retrieve my network key?

Just for your information, the current Z-Wave integration is going to be deprecated and replaced by OZW Daemon.

I’m aware, but that still doesn’t work on my setup last i checked (I should try it again now that i have re-paired all my devices)

Also I need my network key to switch to a new system, but I can’t find it anywhere.

Maybe it’s stored somewhere in the .storage files.

I was only able to set this by setting zwave in the YAML configuration file.

Yes, the .storage contains that information, specifically the .storage/core.config_entries file.

Search for "domain": "zwave" in the file, there you will find data like this:

            {
                "connection_class": "local_push",
                "data": {
                    "network_key": "0x4E, 0x6F, 0x20, 0x6D, 0x6F, 0x72, 0x65, 0x20, 0x73, 0x65, 0x63, 0x72, 0x65, 0x74, 0x73, 0x21",
                    "usb_path": "/dev/ttyACM0"
                },
                "domain": "zwave",
                "entry_id": "596f7520746f6f6b207468652074696d653f",
                "options": {},
                "source": "import",
                "system_options": {
                    "disable_new_entities": false
                },
                "title": "Z-Wave",
                "unique_id": null,
                "version": 1
            },

Thanks, I didn’t think to check that file.

Unfortunately the new integration still crashes with Kwikset locks, so still a no-go for me